1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

my plesk cp broken from upgrading

Discussion in 'Plesk for Linux - 8.x and Older' started by atomicmak, Aug 30, 2005.

  1. atomicmak

    atomicmak Guest

    0
     
    i did autoinstaller from 7.5.3 to 7.5.4 and plesk get broke. then i try to upgrade thourgh rpm's from ssh and getting this now

    ==============================
    Trying to add supplementary group 'psaserv' for user 'psaadm'... already there
    group psacln already exists
    Standard build detected. Upgrading canceled, because only
    5.0.x versions supported for upgrading from Standard to RPM
    builds.

    error: %pre(psa-7.5.4-rhel3.build75050824.12) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-7.5.4-rhel3.build75050824.12
    [root@ns3 base]#
    ==============================

    can please someone help me solving this issue ?
     
  2. atomicmak

    atomicmak Guest

    0
     
    can anyone please help me to solve this ?

    i am really in big trouble right now.
    as plesk autoupdater failed and stopped on half.

    libssl.so is not found.
     
  3. kabarty

    kabarty Guest

    0
     
    Plesk really is an untested abominable piece of **** isn't it...

    I'm suffering exactly the same problem. Tried to fix a broken autoupdate by using the rpms to be told it can't do it.

    Now I have 100 hosed customers. Thanks Plesk
     
  4. gltich

    gltich Guest

    0
     
    You should never do upgrades on a live system! Haven't you tested you upgrade in a non live environment?

    You should always test the upgrade on a test server, so you can find out if al updates are correctly, are that you need to upgrade some packages. That way you can minimize downtime on your servers.
     
  5. kabarty

    kabarty Guest

    0
     
    Thank you for your enlightened reply.

    My ire is largely down to the fact that the upgrade went absolutely fine on a test server and barfed itself all over the floor on the live server, despite them both being Fedora Core 2 with the same software installed. So yes, I am well aware of the importance of doing test runs first.

    Clearly the wind was in the wrong direction when I did the live install or perhaps the phase of the moon had changed sufficiently to cause issues.
     
  6. gltich

    gltich Guest

    0
     
    That sucks:(
    There are no package differences at all?
    If the systems are equal, it _should_ work.

    Is everthing fixed now?
    I don't know about Fedora Core. We only use FreeBSD based systems for hosting.
     
  7. kabarty

    kabarty Guest

    0
     
    Hiya,
    I can only assume that something about the systems was unequal (perhaps the number of customers hosted on it?) but I can't see what it was unfortunately.

    At this point it looks very much like a complete system re-install is the only way out, which does ****, greatly.

    Ah well, all in a days work eh? :)
     
  8. kabarty

    kabarty Guest

    0
     
    Well I have to say, that although the upgrade blew up originally, once I had the server reinstalled (a drastic measure but one that was highly recommended) I used psarestore to put all my customers back and it worked like a charm.

    I then upgraded to 7.5.4 and that too worked like a charm. Apparently my 7.5.3 database had got some weird entries in it (?) and this caused the normal upgrade path to die completely.

    Anyway, I'm all back up and running and everything seems hunky dory!
     
Loading...