1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Mysql 4.1.9 & Plesk's Internal PHP

Discussion in 'Plesk for Linux - 8.x and Older' started by maltune, Jan 21, 2005.

  1. maltune

    maltune Guest

    0
     
    Hi,

    I just upgraded my Fedora core 2 server to Mysql 4.1.9 using the RPMs from mysql.com No problems. I had to rebuild PHP for Apache in order to get the new Mysql version working with PHP. Now it looks as if I'll need to update the PHP module used for the plesk interface. It's currently using Client API Version: 4.1.7 for Mysql. How can I update Plesk's PHP module without affecting anything else and of course not breaking my Plesk installation?

    I realized there was a discrepancy in Plesk and the new version of MySQL when I tried to delete a domain and received the following error message:
    -------
    -------

    So far this is the only problem I've encountered since upgrading MySQL.

    Any suggestions?

    Thanks in advance,
    Jeremy Dunn
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You'll have to wait for sw-soft to modify the code to support mysql 4.1, I've looked at the internals on this one and without being able to modify the sql queries internally in the PSA php code, you cannot resolve this. Your other option would be to run mysql 4.1 in parallel with 3.x or 4.0.x on a different port or socket
     
  3. frozen

    frozen Guest

    0
     
    I have 4.1.x on FreeBSD, and it has worked fine. It came with that version, though I recompiled my own version.
     
  4. VeronicaB

    VeronicaB Guest

    0
     
    I am experiencing the same problem, we have MySQL 4.1.9 and today I tried removing a domain for the first time, and I get the same error message, mentioning an error in MySQL query.

    Did you find a fix for this?

    Thanks!
    Veronica
     
  5. fastemul

    fastemul Guest

    0
     
    UP
    Same pb
     
  6. fastemul

    fastemul Guest

    0
     
    Is it easy to do this ? Could you explain more please because i'm interested by that way ?

    Regards
     
  7. SoundsO

    SoundsO Guest

    0
     
    I have the same problem with Plesk 7.1. and MySql (Thread ). Is MySql >= 4.1 not supported? The Plesk installation guide says that mysql-4.0.15-9.i586.rpm or newer is required. No way to fix this at the moment? I don't want to install a older version.
     
Loading...