1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

mysql SQL Error : 1036

Discussion in 'Plesk for Linux - 8.x and Older' started by kyron2u, Oct 25, 2005.

  1. kyron2u

    kyron2u Guest

    0
     
    Hi, my mysql crashed. luckily i backedup my databases through ssh.

    now my host they slice my dedicated server and restored it.

    so i reinstall my database through plesk and reuploaded my tables i use phpbb.com for my forums.

    now its giving me this error when i try to access my site.

    ive search mysql.com but its confusing.
    can anyone please help

     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    "read only" is a hint.

    Is the version of mysql the same as it was before the crash, or did the host put a newer version (4.1x)?

    If you used to run 3.23 and are now running 4.xx you need to run the command (per mysql.org):

    /usr/bin/mysql_fix_privilege_tables

    (depending on your distro, the path may be different)

    If that does not solve it, then you need to verify the database user permissions.
     
  3. kyron2u

    kyron2u Guest

    0
     
    its the same version.
    see what i think it is that since i reuploaded the databases through ssh, it now has root permissions and the database is trying to edit the database and its not letting it.
    i've tried chmod a+x but that didnt work either.

    ive tried what u just told me, but i got this error.


     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    Use the chown command to set the user and group to mysql
    Code:
    cd /var/lib/mysql
    chown mysql:mysql name-of-database-you-uploaded
    
    The path may depend on your distro, but you already know where the directory is...
     
  5. kyron2u

    kyron2u Guest

    0
     
    that doesnt work :(

    i dont know what else to do.

    thanks again
     
Loading...