• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

mysql upgrade

Which I used on a standard 7.5 install and got this error:

Unable to connect to database: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) 0: /usr/local/psa/admin/auto_prepend/auth.php3:66 psaerror(string "Unable to connect to database: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)")


Any help appreciated.

Thanks
 
w3it, check that your mysql server is working at all. Try this and send the results here:

# service mysql status
or
# service mysqld status

and also:

# ps ax | grep mysql
 
What an error. Brought down Plesk because of a restart was needed. Maybe something in yum could at least say "Now restart MySQL".

Thanks for all your help
 
Thats a bad trigger in the psa, you'll get the same result when updating mysql 3 packages as well.

Fortunately its a benign error, mysql 4 (or a newer mysql 3 for that matter) is successfully being installed, however psa will report mysql 3 (or older version thereof) as being installed in the CP, due to aforementioned bad trigger.
 
Back
Top