1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

need to make Plesk STOP starting qmail/email services at boot. how?

Discussion in 'Plesk for Linux - 8.x and Older' started by jaymer, Jun 3, 2005.

  1. jaymer

    jaymer Guest

    I decided I wanted to use the QmailRocks and its addons on my Fedora 2 NEW server. Problem is that I installed it and cannot make Plesk STOP using its own method of controlling qmail/send/pop3 services.

    If I follow the entire QMR install guide, i get to a problem that the send, pop3 & smtpd services won't stay "up" (qmailctl stat) because the log reports the address is already in use.

    If I use service management (in plesk) to stop courier/pop3, then those 2 services will start now and "qmailctl stat" will show them up now successfully. But smtpd will still be down. If i can figure out how to disable Plesk's Qmail when the server boots, then i might have a chance of my own stuff working.

    Its driving me crazy after a week of messing around with this.
    I'm not on the latest dot-release of plesk - my version has that bug where you cannot manually stop qmail, so i'd like to be told what config/setup files to modify to stop qmail from starting... more specifically "smtpd"

    i hope someone can help me please
  2. adenker

    adenker Guest

    To avoid qmail (actually xinetd) binding to 25th port you should run this commands (only in RH* and FC* OS):

    chkconfig smtp_psa off
    chkconfig smtps_psa off

    then to prevent qmail from starting you should edit /etc/init.d/psa and find following string:

    service="${named_service} mysqld qmail courier-imap"

    end delete 'qmail' from it. Then, using chkconfig turn off qmail on 3rd and 5th errorlevels:

    chkconfig --level 35 qmail off
  3. jaymer

    jaymer Guest

    thx arthur for the reply
    i had already found the service line in the init.d file... so removing that had stopped qmail from starting... but had not done the chkconfig lines. i have done it now.

  4. dstanley

    dstanley Guest

    Hi Jaymer,

    Just wanted to ask when you use the qmail rocks installation, can you still manage your email acounts through PSA?

    Does it all work seemlessly?