1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Need urgent help - PHP 5.2 on Plesk 10.3.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by FirstPoint, Oct 10, 2011.

  1. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    Hello all,

    We just migrated to a new server: Plesk 10.3.1. The installation provided by the autoinstaller of Plesk was with PHP 5.1.6 (!!!).

    PHP 5.2 is needed by most applications our customers use (Magento, Joomla, etc). But we don't want to upgrade to PHP 5.3 as there are too many obsolete functions that are still used (especially in Joomla).

    We want to upgrade to PHP 5.2.x on our Plesk. But unable to do so: autoinstaller doesn't propose it. Atomic proposes only 5.3.

    I don't understand how come Parallels is packaged only with 5.1.6, which is >2 years old !

    Any help will be greatly appreciated, thanks !!
     
  2. figjam

    figjam New Pleskian

    22
    57%
    Joined:
    Mar 28, 2007
    Messages:
    19
    Likes Received:
    0
    No, the version of php provided by versions of CentOS prior to 5.6 is 5.1.6 (see this CentOS wiki article 13. Is PHP 5.2.5 released for CentOS?). Don't blame Parallels for a CentOS issue. CentOS 5.6 and 5.7 also provide the php53 packages.

    I don't know about Magento but Joomla versions 1.5.15+ are PHP 5.3 compatible. It's only crappy, legacy Joomla extensions that aren't.

    The following message has been included in all PHP release announcements since PHP 5.3.6
    All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.x

    You can select PHP 5.3 as an option. If you're determined to upgrade to 5.2, you need to add a repo file to /etc/yum.repos.d/ with the following contents:

    [c5-testing]
    name=CentOS-5 Testing
    baseurl=http://dev.centos.org/centos/5/testing/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing


    You can find more info here: HowTosPHP 5.1 To 5.2 but take a hint when even CentOS themselves are telling you:
    WARNING: php version 5.2.6, as described later in this document is obsolete and prone to security issues. Please consider either upgrading to php53 as included in CentOS 5.6 or use the IUS Community Repo

    The page says it's for 32 bit but it worked fine with 64 bit as well. The main trick with the CentOS Testing repository is that the package names will still be php-* after upgrading, which you need for Plesk to see them. I think the packages from the IUS Community Repo mentioned in the warning at the top of the page are named php52-* and I don't know if that will work with Plesk.

    As I said before, it's because Parallels use the packages supplied by the OS. You could always use a debian 5 container which comes with PHP 5.2.6 by default.

    Cheers,


    Andrew
     
  3. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    figjam, thanks for your answer.

    I know that we are supposed to pass to 5.3, it's not my or our company that doesn't want to... but our customers. Many customers are still running on Joomla 1.0. And what do you want to explain to them, most of them have a very low level of knowledge in real server management.

    Anyways, we've upgraded to PHP 5.3, sent a notice to our customers, and that's it. Way too complicated, and not secure/unstable to stay on 5.2
     
  4. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    You'll want to learn about Red Hat's habit of backporting security fixes. If you want an OS with the latest software, you shouldn't run a nice stable enterprise distribution like RHEL or CentOS. :)
     
Loading...