1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

.NET Framework is not installed

Discussion in 'Plesk for Windows - 8.x and Older' started by DennyDotNet, Feb 5, 2008.

  1. DennyDotNet

    DennyDotNet Guest

    0
     
    Why when I run the aspnetcfg command-line utility does it tell me that ".NET Framework version 2.0... is not installed" ? Also when I click the ASP.NET button on my domain control panel I receive an error:

    System.Exception: .NET Frameword version 2.0.50727.0 not found.
    at ASPNETConfigure.ASPNETConfiguration.normalizeFrameworkVer(Version ver)
    at ASPNETConfigure.ASPNETConfiguration.getFrameworkVerPath(Version ver)
    at ASPNETConfigure.ASPNETConfiguration.getMachineConfigFilePath(Version ver)
    at ASPNETConfigure.ASPNETCfgApp.run(String[] args)
    at ASPNETConfigure.ASPNETCfgApp.Main(String[] args)


    I run the aspnet_regiis -lv utility and I have verified that ASP.NET 2.0 is installed:

    >aspnet_regiis -lv
    2.0.50727.0 Valid (Root) C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\
    \aspnet_isapi.dll
    2.0.50727.0 Valid (Root) C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\as
    pnet_isapi.dll

    I am using the 32-bit version.
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please check IIS works in 32 bit mode
     
Loading...