1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

New Install on RHEL 4.0 ES

Discussion in 'Plesk for Linux - 8.x and Older' started by matt.simpson, Apr 1, 2006.

  1. matt.simpson

    matt.simpson Basic Pleskian

    25
     
    Joined:
    Sep 12, 2001
    Messages:
    94
    Likes Received:
    0
    I'm trying to install Plesk on a fresh RHEL 4.0 ES box using Autoinstaller 3 and it checks to see what RPM's may be missing that Plesk requires.

    The problem is that my box is up2date and Plesk's autoinstaller is looking for an old version of the selinux-policy-targeted rpm, because it can't install the old version over the new version, the installation is failing:
    Any ideas?

    ~Matt Simpson
     
  2. vahiker

    vahiker Guest

    0
     
    I had a smiliar problem on a new Centos4.3 install. I had to remove the newest rpm and re-ran the autoinstaller which than installed fine. I than updated back to the newest rpm after the install.
     
  3. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    or install manually the selinux-policy-targeted-sources rpm that match your selinux-policy-targeted rpm version.
     
  4. matt.simpson

    matt.simpson Basic Pleskian

    25
     
    Joined:
    Sep 12, 2001
    Messages:
    94
    Likes Received:
    0
    Actually what I ended up doing was:

    1. Start the autoinstaller and go to the screen which asked me to choose what options I wanted to install.

    2. Opened up a new terminal window and opened up /root/psa/PSA_8.0.0/plesk-8.0.0-rhel4-i386.inf3 in vi. Changed:
    Code:
    <package file="selinux-policy-targeted-1.17.30-2.110.noarch.rpm" name="selinux-policy-targeted" version="1.17.30" release="2.110" arch="noarch" md5="81c7227d156e53bdc8b1e1afc626f854" buildtime="1126546011" size="110685" />
    
    and
    Code:
    <package file="selinux-policy-targeted-sources-1.17.30-2.110.noarch.rpm" name="selinux-policy-targeted-sources" version="1.17.30" release="2.110" arch="noarch" md5="2fceb485f863b57fb6a546528bc7c16d" buildtime="1126546011" size="168114" />
    TO:
    Code:
    <package file="selinux-policy-targeted-1.17.30-2.126.noarch.rpm" name="selinux-policy-targeted" version="1.17.30" release="2.126" arch="noarch" md5="81c7227d156e53bdc8b1e1afc626f854" buildtime="1126546011" size="110685" />
    
    and
    Code:
    <package file="selinux-policy-targeted-sources-1.17.30-2.126.noarch.rpm" name="selinux-policy-targeted-sources" version="1.17.30" release="2.126" arch="noarch" md5="2fceb485f863b57fb6a546528bc7c16d" buildtime="1126546011" size="168114" />
    Basically, just replaced 2.110 with 2.126, saved the file and continued within the auto installer.

    ~Matt
     
  5. jchost

    jchost Guest

    0
     
    Its awfully upsetting that simple bugs like that are getting past SWSoft.
     
  6. matt.simpson

    matt.simpson Basic Pleskian

    25
     
    Joined:
    Sep 12, 2001
    Messages:
    94
    Likes Received:
    0
    I don't think it's a bug really... if you think about it, it sort of makes sense. They're putting the latest version they've tested with into their autoinstaller utility.

    I think it's more of an design issue really... they should either ensure that their repository is updated daily with RedHat's latest updates or they should simply add a check to not only make sure the package is installed, but also check that if it is installed the version is greater than or equal to the version they're saying should be installed.

    ~Matt
     
Loading...