1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

New plesk 8.0.1 on FC4

Discussion in 'Plesk for Linux - 8.x and Older' started by Flob, Jun 19, 2006.

  1. Flob

    Flob Guest

    0
     
    I built a fresh server to migrate over to as my old server was having disk problems.

    Plesk built okay and the restore was okay.

    However, If I try to visit the web setting for a domain or create a new physical hosting, I get the following error;

    ----cut here----
    Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng failed: usermng: No entry found for path /var/www/vhosts in mounted System error 2: No such file or directory

    ----

    0: /usr/local/psa/admin/plib/common_func.php3:174
    psaerror(string 'Unable to assign variables for PHostingForm: Unable to get hardquota state: usermng failed: usermng: No entry found for path /var/www/vhosts in mounted System error 2: No such file or directory')
    1: /usr/local/psa/admin/htdocs/domains/hosting/phosting_setup.php:293
    ----cut here---

    Any ideas anyone?
     
  2. Hostasaurus@

    Hostasaurus@ Guest

    0
     
    Did anyone find a resolution for this? We're having the same problem on multiple new P8 installs.
     
  3. Flob

    Flob Guest

    0
     
    yes,

    After some assistance with support and them loging in to take a look around.

    Basically usermgr cannot find the vhosts directory as the path in php.ini points to /var/www/vhosts

    However of you look at the mount tab, / is not mounted in the way plesk expects it, as in my FC4 the mount tab was using /volgroup/logvolgroup00 instead of /dev/hda1

    They pointed this out but didn't offer a fix.

    I fixed the problem by mounting / again from /dev/hda1

    regards
    Lawrence
     
  4. blueprins

    blueprins Guest

    0
     
    I have the same problem. And I look my Folders and I have also have a VHOSTS folder as /var/www/vhosts/

    But Why is the reason of the Bug?
     
  5. Flob

    Flob Guest

    0
     
    I don't understand yet!

    mount /dev/hda1 -t ext3 / -o rw,usrquota

    fixes the problem

    my fstab looks like;

    cat /etc/fstab
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/VolGroup00/LogVol00 / / ext3,usrquota defaults 1
    LABEL=/boot /boot ext3 defaults 1 2
    /dev/devpts /dev/pts devpts gid=5,mode=620 0 0
    /dev/shm /dev/shm tmpfs defaults 0 0
    /dev/proc /proc proc defaults 0 0
    /dev/sys /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
    /dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0

    but the mtab looks like;
    cat /etc/mtab
    /dev/proc /proc proc rw 0 0
    /dev/sys /sys sysfs rw 0 0
    /dev/devpts /dev/pts devpts rw,gid=5,mode=620 0 0
    /dev/hda1 /boot ext3 rw 0 0
    /dev/shm /dev/shm tmpfs rw 0 0
    none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
    none /var/named/run-root/proc proc rw 0 0
    sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
    automount(pid1850) /misc autofs rw,fd=4,pgrp=1850,minproto=2,maxproto=4 0 0
    automount(pid1896) /net autofs rw,fd=4,pgrp=1896,minproto=2,maxproto=4 0 0

    Regards
    Lawrence
     
  6. DataHive

    DataHive Guest

    0
     
  7. DCNet_James

    DCNet_James Guest

    0
     
    Fix is: backup your fstab file before installing PSA. Restore it after the PSA install, if it indeed jacks of the file, if not well no need to restore it. Some errors I've seen put the userquota option next to the filesystem type and some put an extra mountpoint in. Either way, all PSA needs added is the userquota option for quota management on whatever partition has your Plesk Product Root.

    SW-Soft strikes again with a bug. WOOHOO!

    Can't wait for PSA 8.0.1 patch 2 and 3 and 4. Eventually after 3 or 4 patches everything seems to get fixed.

    Flob: Case in point, see your fstab entry:
    /dev/VolGroup00/LogVol00 / / ext3,usrquota defaults 1

    Should be more like:
    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota 1

    Something along those lines.

    Thx
    J
     
  8. DataHive

    DataHive Guest

    0
     
    Pretty much, just needs one more digit on the end to specify the 'fsck' option. Quote:

    fsck looks at the number in the 6th column to determine in which order the filesystems should be checked. If it's zero, fsck won't check the filesystem. [http://www.tuxfiles.org/linuxhelp/fstab.html]

    Sam
     
Loading...