1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ODBC error

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Ernie@, Feb 3, 2012.

  1. Ernie@

    Ernie@ Basic Pleskian

    23
    57%
    Joined:
    Aug 27, 2005
    Messages:
    36
    Likes Received:
    0
    PLESK 10.4.4 upgraded. CENTOS 5.7 X86_64, MySQL 5.5.14

    Hi, I've fixed the problem for ODBC caused problem for accessing to the panel. I've removed all records from the tables,
    smb_apsMetas, smb_apsPackages, smb_apsPackagesCategories, then the panel is accessable like a normal one.

    However, there's one last problem, when I access the

    Server Management > Tools & Settings > Application Vault, the same error is appeared.

    --------------
    Message: [unixODBC][MySQL][ODBC 5.1 Driver]Access denied for user 'psaadm'@'localhost' (using password: NO)
    File: aps_php.php
    Line: 7476
    Type: Exception

    ---- LOG FILE ---
    2012-02-03T00:21:10-08:00 CRIT (2): Exception: [unixODBC][MySQL][ODBC 5.1 Driver]Access denied for user 'psaadm'@'localhost' (using password: NO)
    file: /usr/share/aps_php/aps_php.php
    line: 7476
    code: 0
    2012-02-03 00:21:10: (mod_fastcgi.c.2588) FastCGI-stderr: Exception: [unixODBC][MySQL][ODBC 5.1 Driver]Access denied for user 'psaadm'@'localhost' (using password: NO)
    file: /usr/share/aps_php/aps_php.php
    line: 7476
    code: 0
    trace: #0 /usr/share/aps_php/aps_php.php(7476): aps_registry_packagebrowser_browse(Resource id #208)
    #1 /usr/local/psa/admin/panel/application/library/AdminPanel/View/List/AppUsage.php(45): APS_Registry_PackageBrowser->browse()
    #2 /usr/local/psa/admin/plib/CommonPanel/View/List/Abstract.php(360): AdminPanel_View_List_AppUsage->_getDataProvider()
    #3 /usr/local/psa/admin/plib/CommonPanel/View/List/Abstract.php(171): CommonPanel_View_List_Abstract->_setupPaginator()
    #4 /usr/local/psa/admin/panel/application/library/AdminPanel/View/List/AppUsage.php(18): CommonPanel_View_List_Abstract->__construct(Object(Zend_View), Object(Zend_Controller_Request_Http))
    #5 /usr/local/psa/admin/panel/application/controllers/AppController.php(74): AdminPanel_View_List_AppUsage->__construct(Object(Zend_View), Object(Zend_Controller_Request_Http), NULL)
    #6 /usr/local/psa/admin/panel/application/controllers/AppController.php(60): AppController->_getUsageList()
    #7 /usr/local/psa/admin/plib/Zend/Controller/Action.php(513): AppController->usageAction()
    #8 /usr/local/psa/admin/plib/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('usageAction')
    #9 /usr/local/psa/admin/plib/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #10 /usr/local/psa/admin/panel/application/library/AdminPanel/Application/Web.php(20): Zend_Controller_Front->dispatch()
    #11 /usr/local/psa/admin/panel/application/public/index.php(15): AdminPanel_Application_Web->run()
    #12 {main}

    -------------


    Tried following to receat package, but, doesn't help. Nothing is done to the DB.

    /usr/local/psa/admin/bin/php -dauto_prepend_file="" /usr/local/psa/admin/plib/scripts/aps-controller-data-import.php

    Checked for this thread, doen't help.

    http://forum.parallels.com/showthread.php?t=112645

    1. Can you let me know which table that the Application Vault is trying to access?
    2. How can I recreate Application Vault on 10.4.4?
    3. Where to find the final database the panel is using ? eg, for APSC, there are APSC, APSC_xxxx databases, etc. I can try to trace the priviledges for the correct database.

    Thanks.
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
Loading...