1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Open DNS

Discussion in 'Plesk for Windows - 8.x and Older' started by pleuck, Apr 12, 2006.

  1. pleuck

    pleuck Guest

    0
     
    There's a lot of hype right now about open DNS and dns cache poisoning.
    To close DNS recursive enquiries with Plesk uncomment as directed in
    C:\Program Files\SWsoft\Plesk\dns\etc\named.user.conf

    Restart Plesk nameserver

    Some infoormation here:
    http://www.seoconsultants.com/tools/dns/recursion/
     
  2. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    how i do that with MS DNS?
     
  3. pleuck

    pleuck Guest

    0
     
  4. osv1

    osv1 Guest

    0
     
    thanks a bunch paul! i think that i got it working.

    taking it a step further... since plesk uses bind for winxp server 2003, can we also enable recursive lookups only for the local network? similar to this:

    Use a line "recursion no;" in the "options" clause (or in the "view" clause)
    If you need to enable recursion for your local network, you can use a "allow-recursion { ADD_LIST_OF_YOUR_IP_RANGES_HERE; }" line in the "options" section.
    [Use caution; BIND files are easy to break]
    http://www.dnsreport.com/info/opendns.htm
     
  5. JackL

    JackL Guest

    0
     
    MS DNS, doesn't provide selective recursion disabling per interface

    John S.G.
     
  6. osv1

    osv1 Guest

    0
     
    i agree, you can't use selective recursion with ms dns, so the question is, can you do it with the plesk bind function?

    local network recursion could be important for a lot of sites.
     
  7. rmmoore80

    rmmoore80 Guest

    0
     
    When I disable dns recursion, my outgoing mail stops as SmarterMail is unable to get the MX records for external domains. Is there a work around or fix for this?
     
Loading...