1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Open_basedir error - Blank website

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by LiderL, Apr 8, 2012.

  1. LiderL

    LiderL Guest

    0
     
    Hi all,

    I have the following problems...
    I have a dedicated server with centos 6.2 and plesk 10.4.4
    I have a website on this server. On site frontend, I can not change the language. Shows only default language. I had solved this problem with disable open_basedir.
    I installed server again. And if I disable open_basedir in domain php setting with "none" or "no value", shows website only blank pages.
    I must, disable the open_basedir. I still get another error bask on website.
    Who can explain very clearly, how can this blank website problem be solved?

    I've done everything what read on the internet. I have all vhost.conf, httpd.conf. php.ini files changed but result was zero.
     
  2. LiderL

    LiderL Guest

    0
     
    I have written here a week ago a problem. Received any response. There are no competent people to answer me?

    This is problem after update (from 10.3.x to v10.4) occurred.

    I've also discovered that, when I upload on my website index.php file, I get internal 500 error. When I upload files with index.html or .html extension, not a problem.
     
  3. OpenSpark

    OpenSpark Guest

    0
     
    We have the same configuration - dedicated server with CentOS 6.2 and Plesk 10.4.4. After one of the recent MU's we are unable to turn off the openbasedir restriction while running PHP as an Apache module without get a blank white screen. Running PHP as FastCGI is still working fine.
     
  4. LiderL

    LiderL Guest

    0
     
    Thank You for Your Reply.

    I can not use FastCGI. Because if I enable Fastcgi, get on my website many errors. It must be fixed on Apache module.
    But how?
     
  5. JuliuszR

    JuliuszR New Pleskian

    10
    85%
    Joined:
    May 13, 2012
    Messages:
    14
    Likes Received:
    0
    We have the same configuration -
    dedicated server with CentOS 6.2 and Plesk 10.4.4.
    When i put in comfig from server on plan level, subscription level and domain level open_basedir to none
    i get a blank white screen, nothing works.
    In php.ini in etc -open_basedir is = blank

    What to do?
    Can anybody help?
    Can anbody from Plesk staff simple write -How to configure the Plesk that open_basedir works on domain without value?

    Pls,
    it is time to do something

    Juliusz
     
  6. AlanB1

    AlanB1 Guest

    0
     
    Disable openbase_dir site wide

    To remove open_basedir in Plesk, please follow these steps:

    Connect to your VPS using a shell (SSH) connection.
    Change to the root folder of your VPS using the following command:
    Code:
    cd ...
    
    Create a new file using the following command:
    Code:
    vi /etc/httpd/conf.d/zzz_openbasedir_removal.conf
    
    Press the insert key and enter the following information:
    Code:
    <DirectoryMatch /var/www/vhosts/(.*)/httpdocs/>
    php_admin_value open_basedir none
    </DirectoryMatch>
    
    Press escape (ESC) to exit insert mode.
    Type :wq to save and exit the file.

    run the following command on shell (SSH) to update the plesk config files
    Code:
    /usr/local/psa/admin/bin/httpdmng --reconfigure-domain <domain_name>
    
    restart your web server again.
    Code:
    /etc/init.d/httpd restart
    
    open_basedir should now be removed from Plesk.
     
Loading...