1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Password Change through Webmail/Horde not possible

Discussion in 'Plesk for Linux - 8.x and Older' started by Porthos, Jan 8, 2005.

  1. Porthos

    Porthos Guest

    0
     
    Hello!


    A password change of a Email POP account through Plesk is possible (We use Plesk 7.5.1 with Suse Linux), but if anybody tries to change his password through Webmail / Horde he gets the following English error:
    Code:
    Warning: fsockopen(): unable to connect to localhost:106 in /home/httpd/vhosts/webmail/horde/passwd/lib/Driver/poppassd.php on line 34
    Failure in changing password : Connection refused
    and with the German version this error:
    Code:
    Warning: fsockopen(): unable to connect to localhost:106 in /home/httpd/vhosts/webmail/horde/passwd/lib/Driver/poppassd.php on line 34
    Fehler  Fehler beim Ändern des Passworts : Verbindungsaufbau abgelehnt
    Does anybody know how to solve this error?
     
  2. tpujals

    tpujals Guest

    0
     
    in the case of this user do they have plesk access? I think if they have control panel access they cannot change their PW thru plesk. Just disable control panel access for this user.

    I tested my horde and it changed the pw just fine. My user does not have control panel access though.
     
  3. Porthos

    Porthos Guest

    0
     
    Thank you for your quick answer, but I tested both. I both cases - with and without control panel access to Plesk - I get this error.

    A password change is in both scenarios only over Plesk possible and in both cases not through Webmail / Horde.
     
  4. murali.r

    murali.r Guest

    0
     
    First of all make sure that popassd service is working fine in the server. Webmail uses this service for changing passsword.

    In the file /home/httpd/vhosts/webmail/horde/passwd//config/backends.php
    change localhost with the server IP in the serction.
    $backends['poppassd'] = array(
    'name' => 'Example poppassd server',
    'preferred' => '',
    'password policy' => array(),
    'driver' => 'poppassd',
    'params' => array(
    'host' => 'localhost', ===> change localhost to server IP
    'port' => 106
    )

    It should work

    Regards,
    Murali:)
     
  5. Porthos

    Porthos Guest

    0
     
    Thank you, but I get same error message. Of course now the error message shows my IP-Address instead of 'localhost'.

    Any other ideas?
     
  6. Phil@

    Phil@ New Pleskian

    22
    90%
    Joined:
    Oct 22, 2001
    Messages:
    23
    Likes Received:
    0
    Do you run any Firewall? If yes check if you have opened port 106.
     
  7. Porthos

    Porthos Guest

    0
     
    I use only the Firewall-functions of Plesk and I tried to open Port 106 explicit, but unfortunatly this does not solve the problem, too.
     
  8. vishnu

    vishnu Guest

    0
     
    What does the /tmp/horde.log say ?

    What is the result of "telnet localhost 106", from within the server?
     
  9. TheGamer1701

    TheGamer1701 Guest

    0
     
    I'm having the same problem.

    i opened port 106 through the Plesk Admin interface.
    I also changed the "localhost" to my servery ip adresse


    still it's not working.
    I really need help here.


    I tried the "telnet localhost 106" command and it returns:

     
  10. apro2000

    apro2000 Guest

    0
     
    encountering the same problem as mentioned above tried the same things, noting worked, has anybody an idea??
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you are using a RH type system, make sure xinetd is running and listening on that port:

    [root@ns2 xinetd.d]# netstat -npa |grep '106'
    tcp 0 0 0.0.0.0:106 0.0.0.0:* LISTEN 1342/xinetd

    The poppassd_psa should look like:

    [root@ns2 xinetd.d]# cat poppassd_psa
    service poppassd
    {
    socket_type = stream
    protocol = tcp
    port = 106
    wait = no
    disable = no
    user = root
    instances = 1000
    flags = KEEPALIVE
    server = /usr/local/psa/admin/bin/poppassd
    }

    Try restarting xinetd
     
  12. apro2000

    apro2000 Guest

    0
     
    it's suse :-(...
     
  13. apro2000

    apro2000 Guest

    0
     
    problem still exists, has anybody an idea?
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    @apro2000 - Did you ever try what vishnu suggested?
    SSH into the server as root and issue that command from the shell prompt. If port 106 is responding from within the server itself, then you should see:
    If you see something like the following, then poppassd is either not running, or port 106 is being blocked:
    I am not familiar with Suse commands, but there should be something similar to the 'netstat' command in other Linux's.

    I use: netstat -npa |grep '106' and get an output like:
    Which tells me that my xinetd daemon is listening on port 106.
     
  15. apro2000

    apro2000 Guest

    0
     
    ok seems like no popassd or anything else is listening on '106'...
     
  16. apro2000

    apro2000 Guest

    0
     
    Funny things happen,

    after now upgrading to PLESK 7.5.2 --> 7.5.3
    everything works...strange..thanks anyway!
     
  17. jean-david

    jean-david Guest

    0
     
    Same problem

    I have the same problem with the latest plesk 7.5.4 and the additionnal horde components.
    However, I have no poppassd daemon running:
    Code:
    root@kmail:/# telnet localhost 106
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    root@kmail:/#    
    I think I have poppassd installed, since
    Code:
    root@kmail:/# locate poppass
    /opt/psa/admin/bin/poppassd
    /opt/psa/admin/sbin/poppassd
    /usr/share/psa-horde/passwd/lib/Driver/poppassd.php
    /var/lib/nessus/plugins/poppassd_too_long_user.nasl
    /var/qmail/users/poppasswd
    root@kmail:/# 
    How to start the poppassd ? Can it be configured somewhere ?
     
  18. reeq_18

    reeq_18 Guest

    0
     
    i have same problem in this case

    my box use FreeBSD
    i can't open port 106
     
Loading...