• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Permenently deleting Plesk created files from terminal

Hi all -

I have Plesk 12.0 running on a CentOS 6.5 server.

The server recently ran out of diskspace. So entirely that I cannot access Plesk control panel - I receive the error detailed at kb.odin.com/en/117929. My disk usage is reported as follows:

#df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup-lv_root 13G 13G 0 100% /
tmpfs 939M 8.0K 939M 1% /dev/shm
/dev/vda1 485M 33M 427M 8% /boot



In order to free up space, I have been trying to delete files/directories by removing their hardlinks (rm -rf). I have removed three unneeded vhost directories, one unneeded mysql DB (via rm -rf /var/lib/mysql/XXX - above error prevents logging into mysql server) several archived log files (audit.log.1 etc). I have restarted the server, restarted nearly every service, searched for hardlinks/processes keeping files open using lsof | grep <inode> and find /path/to/mount/ -inum <inode>. Nevertheless, df -h stays stubbornly at precisely the same output as above.

What am I missing, oh internet?
 
Solved!

There was a runaway process writing junk data to the disk as soon as space was freed. Has been deleted.

It appears Plesk migration manager hung up trying to create mailnames in /var/qmail/mailnames/<migrated.domain> resulting in a 6.1GB file that grew every time is was allowed to.
 
Back
Top