• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Permissions problem with Security Advisor and letsencrypt

LaurentR2D2

Regular Pleskian
Plesk Certified Professional
Hello,

When I try to add a letsencrypt certificate to Plesk with Security Advisor, I get this error message :

sh: 1: /opt/psa/admin/bin/letsencrypt.sh: Permission denied

I can't find where the permission is denied.

Also, when I try to use Security Advisor to add certificates to other domain hosted on my server, letsencrypt is marked as currently working, but it stays at 0% and nothing happens. I have no problem securing my domains with the letsencrypt extension. I can't use this extension to secure Plesk since the the name of my machine is not on one of my domains, and it doesn't appear in the list of domains of the letsencrypt extension.

Thank you
 
Do you have SELinux enabled? Check it with getenforce command.
 
Back
Top