1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Photo Gallery Search Problem

Discussion in 'SiteBuilder' started by eastcoast, Apr 23, 2009.

  1. eastcoast

    eastcoast Basic Pleskian

    24
    73%
    Joined:
    Oct 19, 2005
    Messages:
    54
    Likes Received:
    0
    I have a Photo Gallery page with 2 categories. If you click on the link to a category you get all the photos (multiple pages) but if you click on the category in the dropdown category menu you don't get any photos unless you have a photo with "search" in the photo name. If you remove the word "search" from the search window on the left it displays all the photos. In other words if the word "search" is not removed a search takes place looking for a photo containing the word "search". How can I remove the word "search" from the search window and, ideally, place it beside the search window ? Thanks.
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Actually, behavior is correct and made by design but I understand what you are talking about.

    1. When you click on the category name you get right into the category and all images for this category are displayed.
    2. When you select category from listbox (drop-down menu) you just select one of the parameters for search. By default search field contains "Search" word (so customers understand that this field is for search) and if you do not re-define it you will get search result for ''Search' word.

    As a workaround in this case you can try to remove "Search" word from locale definition in following files:

    /usr/local/sitebuilder/resources/locale/en_US/Modules/ImageGallery/Frontend.lng:search = "Search"
    /usr/local/sitebuilder/resources/locale/en_US/Modules/ImageGallery/Frontend.lng:searchImage = "Search"
    /usr/local/sitebuilder/resources/locale/en_US/Modules/ImageGallery/Category/List.lng:search = "Search"
    /usr/local/sitebuilder/resources/locale/en_US/Modules/ImageGallery/Images/List.lng:search = "Search"

    This will affect image gallery only. Just leave it this way: search = "" instead of search = "Search"

    Try it and let me know if it's ok for you.
     
Loading...