1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

php 4.4.0 open_basedir problem

Discussion in 'Plesk for Linux - 8.x and Older' started by netpresent, Oct 16, 2005.

  1. netpresent

    netpresent Guest

    0
     
    please help me: php 4.4.0 weiird open_basedir problem

    I am having a very weird open_basedir problem since i upgraded to php 4.4.0.

    No matter if I set the value for open_basedir to / in /etc/php.ini or vhost.conf, phpinfo() still shows the following local value for open_basedir:

    /home/httpd/vhosts/{domain.name}/httpdocs:/tmp

    That's the value that is written in the httpd.include files, but I thought I could overwrite that in vhost.conf. I can actually overwrite other values with vhost.conf, e.g. the magic quotes, but not open_basedir...

    I wouldn't mind changing a skeleton file for httpd.include either, if I only knew where it was. Or is this hard-coded into plesk somehow?

    Very puzzled,
    any help or hint would be appreciated...

    Joempie
     
  2. netpresent

    netpresent Guest

    0
     
    swsoft doesn't know?

    i would expect someone at swsoft to know why some php values can be set in vhost.conf, but open_basedir cannot?

    please?
     
  3. siren@

    siren@ Guest

    0
     
    In vhost.conf do this:
    <Directory /var/www/vhosts/domain.com/httpdocs>
    php_admin_value open_basedir none
    </Directory>

    I run PHP 4.4.0 from ART and have no problems with this setting.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Re: swsoft doesn't know?

    First, this forum is for Plesk USERS to help each other. Plesk staff do not use this forum by policy.

    Second, open_basedir is not Plesk specific, has been covered in many many posts before, is not difficult to find by using search, other documentation is readily found such as php.net
     
Loading...