1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php errors will not display

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Duckington, May 15, 2012.

  1. Duckington

    Duckington Guest

    0
     
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Parallels Plesk Panel 10.4.4, CentOS 5

    PROBLEM DESCRIPTION
    When there is any kind of error in my php files the error messages are not displayed, nor do they seem to be logged. (I have checked the error log in my domain, but it is not updating with the messages).

    STEPS TO REPRODUCE
    I've go into my domain and to PHP Settings and changed "error reporting" to "E_ALL" and "display errors" to "on", I have also then tried restarting Plesk via SSH. But the errors still are not displayed.

    I've also tried editing the /etc/php.ini file and changing the display_errors to "on" and again restarting Plesk, however they are still not being displayed, and when I view my phpinfo() I see the in the "local" column the errors are set to be displayed, bu in the "master" column they are still "off", even though I have checked the php.ini file again and they should defintely be on.

    ACTUAL RESULT
    Errors are not displayed on page, I just get a white page instead. This is any kind of error, so it could be syntax or it could be a problem opening a stream, etc...

    EXPECTED RESULT
    The error messages to be output to the page
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    We have already submitted bugreport regarding this issue. I have updated it with your case. I hope it will be fixed soon.

    POSSIBLE TEMPORARY WORKAROUND:

    In Panel GUI set error_reporting to custom value and enter numeric value (i.e. 6135)

    "Setting error_reporting in your VirtualHost has to be done through a numerical value which is the result of the options you choose summed up from the values of these options, as defined on the constants page for the error management functions: http://www.php.net/manual/en/errorfunc.constants.php

    As a result, E_ALL & ~E_NOTICE would be set this way (this automatically excludes E_DEPRECATED AND E_USER_DEPRECATED):
    php_value error_reporting 6135


    whereas E_ALL (excluding the deprecated levels) would be set this way:
    php_value error_reporting 6143

    The difference between those two values is 8, which is the value of the constant for E_NOTICE.
     
  3. Duckington

    Duckington Guest

    0
     
    Hi,

    Thanks.

    Hopefully it will be fixed soon, as this is making debugging my websites incredibly difficult... though in my googling around I noticed this seems to have been a problem for about 5 years! So maybe "soon" is a bit hopeful..

    http://forums.digitalpoint.com/showthread.php?t=212709
     
  4. Duckington

    Duckington Guest

    0
     
    That work around seemed to work, thanks.
     
  5. rupeshk

    rupeshk New Pleskian

    10
     
    Joined:
    Dec 6, 2012
    Messages:
    3
    Likes Received:
    0
Loading...