• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PHP-FPM

Vadim_Zigula

Basic Pleskian
I got this error, when i press on process PHP-files by means of nginx. Nex i receive this in plesk panel:

phpinimng failed: Job for php-fpm.service failed. See 'systemctl status php-fpm.service' and 'journalctl -xn' for details. Failed to reload php-fpm service
 
Hi Vadim_Zigula,

... and what is the output of "systemctl status php-fpm.service" , "journalctl -xn" and/or "/etc/init.d/php-fpm status" over the command line?
 
systemctl status php-fpm.service
php-fpm.service - The PHP FastCGI Process Manager
Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled)
Active: active (running) since Sat 2015-01-10 17:55:48 EST; 12h ago
Process: 2720 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
Main PID: 3409
Status: "Processes active: 0, idle: 5, Requests: 11, slow: 0, Traffic: 0req/sec"
CGroup: /system.slice/php-fpm.service
|-3409 php-fpm: master process (/etc/php-fpm.conf)
|-3411 php-fpm: pool www
|-3412 php-fpm: pool www
|-3413 php-fpm: pool www
|-3414 php-fpm: pool www
`-3415 php-fpm: pool www

Jan 10 17:55:48 airliners.lv systemd[1]: Started The PHP FastCGI Process Manager.

or

/etc/init.d/php-fpm status
-bash: /etc/init.d/php-fpm: No such file or directory
 
can`t open my domain name:

403 Forbidden
nginx

systemctl status php-fpm.service
php-fpm.service - The PHP FastCGI Process Manager
Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled)
Active: failed (Result: signal) since Sun 2015-01-11 06:59:29 EST; 3min 32s ago
Process: 9448 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
Process: 9412 ExecStart=/usr/sbin/php-fpm --nodaemonize (code=killed, signal=USR2)
Main PID: 9412 (code=killed, signal=USR2)
Status: "Processes active: 0, idle: 5, Requests: 0, slow: 0, Traffic: 0req/sec"
CGroup: /system.slice/php-fpm.service

Jan 11 06:59:14 airliners.lv systemd[1]: Starting The PHP FastCGI Process Manager...
Jan 11 06:59:14 airliners.lv systemd[1]: Started The PHP FastCGI Process Manager.
Jan 11 06:59:29 airliners.lv systemd[1]: Reloading The PHP FastCGI Process Manager.
Jan 11 06:59:29 airliners.lv systemd[1]: Reloaded The PHP FastCGI Process Manager.
Jan 11 06:59:29 airliners.lv systemd[1]: Reloading The PHP FastCGI Process Manager.
Jan 11 06:59:29 airliners.lv systemd[1]: php-fpm.service: main process exited, code=killed, statu...USR2
Jan 11 06:59:29 airliners.lv systemd[1]: PID 9412 read from file /var/run/php-fpm/php-fpm.pid doe...ist.
Jan 11 06:59:29 airliners.lv systemd[1]: Reload failed for The PHP FastCGI Process Manager.
Jan 11 06:59:29 airliners.lv systemd[1]: Unit php-fpm.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
 
Last edited:
Hi Vadim_Zigula,

you always have the choice to investigate issues/problems and failures with the help of log - entries and/or configuration files.


Please provide some of the depending log - entries and/or configuration files, in order to get to the cause of your issue - sometimes, the output of a command simply isn't enought, as well as just a description to the issue. Be aware, that the more informations you provide, the better will be inverstigations and suggestions from people willing to help you.
 
C
Hi Vadim_Zigula,

you always have the choice to investigate issues/problems and failures with the help of log - entries and/or configuration files.


Please provide some of the depending log - entries and/or configuration files, in order to get to the cause of your issue - sometimes, the output of a command simply isn't enought, as well as just a description to the issue. Be aware, that the more informations you provide, the better will be inverstigations and suggestions from people willing to help you.
Can u help me if i give u ssh access or root pass from panel?
 
Hi Vadim_Zigula,

sorry... I don't do personel support here in the forums, I just help the community in threads.
If you would like personel support, you might consider opening a support - ticket ( Parallels - Support )
 
Back
Top