1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP Version

Discussion in 'Plesk 11.x for Linux' started by MartinEn, Jan 18, 2013.

  1. MartinEn

    MartinEn New Pleskian

    10
     
    Joined:
    Dec 20, 2012
    Messages:
    2
    Likes Received:
    0
    Hi

    We are running: OS CentOS 5.8 (Final)
    Panel version: 11.0.9 Update #33

    In Hosting Settings / PHP Settings it says:
    Your current PHP version is 5.1.6.

    How can we access PHP 5.3 or higher please?

    Martin
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Install PHP 5.3 from the Parallels Plesk Panel web interface:
    Tools & Settings > Panel > Updates > Add Components > select PHP5.3 support and continue.
     
  3. MartinEn

    MartinEn New Pleskian

    10
     
    Joined:
    Dec 20, 2012
    Messages:
    2
    Likes Received:
    0
    Thank you

    I did find it, but the documentation takes a bit of getting used to.
     
  4. www.ServerTechSupport.com

    www.ServerTechSupport.com New Pleskian

    13
    35%
    Joined:
    Mar 13, 2012
    Messages:
    16
    Likes Received:
    0
    Try to upgrade php from shell by login as root

    Note: If it doesn't work then add the atomicorp yum repo and try again.
     
  5. RandyFr

    RandyFr New Pleskian

    10
     
    Joined:
    Jan 23, 2013
    Messages:
    1
    Likes Received:
    0
    HI, I tried the following:

    Install PHP 5.3 from the Parallels Plesk Panel web interface:
    Tools & Settings > Panel > Updates > Add Components > select PHP5.3 support and continue.

    but after Add components >, there isn't any 'PHP5.3 Support', option. How do i get it?
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    What is version of your Plesk?
    What about

    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

    ?
     
Loading...