1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP5 Apache 2 & Plesk 8.0 Issues

Discussion in 'Plesk for Linux - 8.x and Older' started by Xploreweb.com, Jun 13, 2006.

  1. Xploreweb.com

    Xploreweb.com Guest

    0
     
    Hi there,

    Ok first of all i explain quickly why i did it this way. I have a server rhel 4 x86_64 arch with plesk 8. Rhel os came with php 4.3.9. I looked around everywhere to see if there were RPMS for php 5 for x86_64 arch. There was not, so i decided to compile PHP5 with everything i needed. All worked fine, php 5 running superb !

    I compiled localhost and installed with 'make install', therefore no php RPM package is reconized as installed. I threw the old rpms 4.3.9 off.

    Php5 all worked fine with plesk until i did the following: I clicked by accident when adding a domain (in plesk) safe mod on for PHP. Now the problem is.. When you surf/browse to the domain you added or edited it wants to download the PHP files instead of executing them.

    So i was sure plesk changed something in the apache configuration. So i seeked through the files and found the following settings in file '/var/www/vhosts/domain/conf/httpd.include'

    As you can see plesk now disables the PHP engine by putting ' php_admin_flag engine' on OFF. If i put it on ON its working again, but the default in plesk is now screwed up as it always puts it off.

    Now the most horrible part, I can't uncheck any checkbox anymore in plesk as they are checked and disabled. (SEE IMAGE BELOW).

    [​IMG]

    I just got to make sure plesk doesnt disable the php engine anymore under any circumstance, but i can't figure out where and how i can disable or configure that for plesk 8.

    It all worked fine before until i added one domain by accident with safe mode checked.. and since then they are always disabled..

    Help very much appreciated.
    Thank you,

    Timon
     
Loading...