1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.4.4 - Cannot set PHP directives per domain while running FastCGI

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by fidget253, Dec 22, 2011.

  1. fidget253

    fidget253 New Pleskian

    12
    60%
    Joined:
    Dec 21, 2011
    Messages:
    3
    Likes Received:
    0
    I cannot set PHP directives per domain while running fastCGI. All domains were working correct running FastCGI on Plesk 10.3.1. Now it almost seems like the domain level php.ini file is being ignored or not used. Changes were also made to the global configure but this did not work. Any ideas?
     
  2. fidget253

    fidget253 New Pleskian

    12
    60%
    Joined:
    Dec 21, 2011
    Messages:
    3
    Likes Received:
    0
    I also did a find | grep for any file containing a 2M limit. There are no such files



    [root@ruhosting /]# find -name php.ini | grep 2M - gave no results
    [root@ruhosting /]# find -name php.ini - all php.ini files, none have 2M as a value
    ./etc/php.ini
    ./usr/local/psa/admin/conf/php.ini
    ./var/www/vhosts/rileyssweettreats.com/etc/php.ini
    ./var/www/vhosts/uberstine.com/etc/php.ini
    ./var/www/vhosts/ruhosting.me/etc/php.ini
    ./var/www/vhosts/uptime.ruhosting.me/etc/php.ini
    ./var/www/vhosts/perfectdayperfecthair.com/etc/php.ini
    ./var/www/vhosts/footballnewsaustralia.com/etc/php.ini
     
  3. FollowTheMedia

    FollowTheMedia New Pleskian

    13
    35%
    Joined:
    Aug 26, 2011
    Messages:
    14
    Likes Received:
    0
    I've got the same problem: I cannot set the upload_tmp_dir PHP variable, so I got UPLOAD_ERR_NO_TMP_DIR error.

    I tried setting it in the following files, without any success:
    %vhost%/conf/php.ini
    %vhost%/conf/vhost.conf
    /etc/php5/cgi/php.ini
    /etc/php5/cli/php.ini
    /etc/php5/apache2/php.ini

    Then I launched:
    /usr/local/psa/admin/bin/httpdmng --reconfigure-all
    /etc/init.d/apache2 restart

    Nothing to do.

    phpinfo() still tells me that upload_tmp_dir is not set. :(
     
    Last edited: Dec 25, 2011
  4. Powie

    Powie Regular Pleskian

    25
    90%
    Joined:
    May 11, 2007
    Messages:
    101
    Likes Received:
    0
    Location:
    Ilmtal
    It's a shame that Parallels released this buggy version of PLESK. That's one of the biggest errors in the latest release.

    Plesk changes the vhosts to use an own php.ini file for each domain, located in ...vhosts/domain.tld/etc/php.ini, but PLESK doesn't create that file.....
     
  5. FollowTheMedia

    FollowTheMedia New Pleskian

    13
    35%
    Joined:
    Aug 26, 2011
    Messages:
    14
    Likes Received:
    0
    It works! Thanks! You saved my day! :)
     
Loading...