1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10 upgrade failed

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by DavidCH, Nov 3, 2010.

  1. DavidCH

    DavidCH Guest

    0
     
    I attempted to upgrade my GoDaddy dedicated server's (CentOS 5) Plesk 9 to the Plesk 10. I got a first email confirmation of success using
    Parallels Products Installer 3.6.0.
    Ten minutes later, I got another email with Parallels Products Installer 3.7.0 that stated that the install failed.
    Now my Plesk admin is hosed. The psa fails to launch at all now. I tried the command line launching, but it gets a "failed" in response. Now I have no working Plesk.
    ??

    Here are the last few lines in the auto email report I got from the installer:
    ----------------
    => [exec start] 'init/grant_sql.sh' with '/bin/sh' processor
    ERROR 1146 (42S02) at line 1: Table 'mysql.servers' doesn't exist
    => [exec error] 'init/grant_sql.sh' in 0.21 secs
    => [An error occurred while upgrade.]
    => [error on previous startup] Can't continue upgrade process
    Restarting SWsoft control panels server... stale pidfile. stale pidfile. [FAILED]
    error: %post(hspc-release-3.3.3-10090110.i386) scriptlet failed, exit status 255
    Error: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.

    ----------------
    I've attached the entire email report as a .txt file
     

    Attached Files:

  2. Jeff (YaBB World)

    Jeff (YaBB World) Guest

    0
     
    Hi
    I got this Error too in m Email. I am using Debian 5.0 x64 and Plesk Panel 9.5.2 I cannot update to 9.5.3 or to 10.0.0
     
  3. Jeff (YaBB World)

    Jeff (YaBB World) Guest

    0
     
    Hi
    ok, update works today. After I got Email from Parallels.
     
  4. Walter Smith

    Walter Smith New Pleskian

    20
     
    Joined:
    May 13, 2009
    Messages:
    22
    Likes Received:
    0
    what did you do Jess please help us?
     
  5. Jeff (YaBB World)

    Jeff (YaBB World) Guest

    0
     
    Exacly, i only tried update today after get this Email today:

    But another issue. I have update successfully from 9.5.2 to 9.5.3 today. Yesterday was failed. Now I tried update to 10.0 but get this Error. The Key is invalid I think.

    Now I need wait answer from my host to get new key for 10.0 because my host I can see keys only for Plesk 8, Plesk 9.0-9.4 and 9.5
     
  6. HugoG

    HugoG Guest

    0
     
    Plesk not working

    I think Jeff problem was not the same problem as original post.

    I got exactly same problem as Davidsh while upgrading from 9.5.3 to plesk 10 on centOS-5-x86_64.

    Is there a solution else than reinstall whole plesk? What did you do David?

     
  7. Civilian

    Civilian Guest

    0
     
    The problem is caused by password of admin user. Plesk upgrade will fail if password contains symbol "+".
    Parallels Plesk Panel installer could not proceed the password correctly and failed.
     
Loading...