1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk 7.5.4 installation on Fedora Core 3

Discussion in 'Plesk for Linux - 8.x and Older' started by Role, Sep 14, 2005.

  1. Role

    Role Guest

    0
     
    This week I installed Fedora Core 3 on my server. Now I tried to install Plesk 7.5.4 and it worked, but today the apache service could not be started anymore. I read some articles about this subject and it seems httpd is the devil.

    I decided to take no risks and (tried to) reinstalled Plesk. However, while installing this error made the installation to an end.

    When I saw this error I thought: let's check psa.conf in /etc/psa/. When I tried to look at it there wasn't a directory called psa created. How is this possible and what is the solution?

    (Yes I have root access)
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If the /etc/psa directory did not exist prior to your trying to reinstall Plesk, then that would be related to your original problem.

    Directories should not just disappear on their own. Have you checked to make sure you were not rooted/hacked?

    I believe that if the installer thinks that Plesk is already present during a (over the top) re-install, it may assume that the /etc/psa directory already exists, and tries to read the "current" config (which is not there). Obviously on a new install (on a fresh formatted HDD and OS install) it will not find an earlier install of Plesk and will therefore not try to read from /etc/psa, it will create the directory and write it's files.

    My recommendations:

    1. Check for hack/rooted signs.

    2. Restore from a backup

    If you really want to, you can try running the RPM installer file with --force option.
     
  3. Role

    Role Guest

    0
     
    I have deinstalled Plesk like was told on this website. I have done all steps like sw-soft explain. I think it should be deinstalled then.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Never assume that 'de-installing' will actually delete or cleanup all directories, files, databases. Whether under *nix or Windows, most un-installs leave things behind on a system.

    There are many threads on the forum dealing with un-installing, so it is left to the imagination which steps you actually did nor not.

    I still recommend you check for hack/rooted signs unless you formatted the drive and re-installed/re-imaged the OS.
     
Loading...