1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Plesk 7.5.4 Login problem (auth.php3)

Discussion in 'Plesk for Linux - 8.x and Older' started by Seraph@, Sep 2, 2005.

  1. Seraph@

    Seraph@ Guest

    0
     
    Hi there,

    I upgraded Plesk from 7.5.3 to 7.5.4. The upgrade process itself went fine, no errors.

    The problem is, that I cannot login to the cp anymore. It gives me the following error:

    "The file auth.php3 is part of Plesk distribution. It cannot be run outside of Plesk environment."

    My server is running inside a vps environment. Could this cause the problem?

    How can I fix this?

    Thanks in advance
     
  2. w3b1

    w3b1 Guest

    0
     
    Hello,

    I have the same problem
    after the Update from 7.5.3 to 7.5.4:

    after the login I see that



    Please Help me
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have either of you checked all the details of the updater log (should be in /tmp). It will be pretty large, but you should check each line and make sure there were no errors, warnings, dependency problems, etc.

    Actually, if you are running on a VPS, I thought it was recommended to upgrade by a server template instead of using the updater (thought I saw that in another post recently)
     
  4. Seraph@

    Seraph@ Guest

    0
     
    I think I found something:

    "===> Installing /usr/sbin/suexec2 replacement
    Trying to backup original /usr/sbin/suexec2... done
    `/usr/local/psa/suexec/psa-suexec2' -> `/usr/sbin/suexec2'

    WARNING!
    During the Shared object mod_suexec.so not found in /usr/lib/apache2. found some small problems
    Continue..."

    That's the only warning in the log. Everything else went fine.

    Concerning the upgrade by server template... Well, I read that searching for a solution for my problem. It would have been really nice mentioning this in the readme. :rolleyes:


    Btw. Maybe it's helpful to know, that the server is running Suse 9.1.
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, there are a great many things which would be nice if Plesk were to put in the Readme as well as clearly on their download page. I am still waiting for Novell to send me my 9.1 package so I can play around with Suse, I have always been a solid RH fan. So unfortunately, my ability to help further is at an end... :(
     
  6. Seraph@

    Seraph@ Guest

    0
     
    Thanks for trying. :)
     
  7. viperxx

    viperxx Guest

    0
     
    I am having the very same problem after performing an update through the plesk control panel. I need to fix this ASAP, I've tried everything I can think of, has anyone found a solution yet?

    Thank you!
     
  8. death

    death Guest

    0
     
  9. death

    death Guest

    0
     
    Check if you have the file:

    ls -l /usr/lib/apache2/mod_suexec.so

    Otherwise check if it's somewhere else installed:

    find /usr/lib -name mod_suexec.so

    If you found it, do a symlink from that location to /usr/lib/apache2:
    ln -sf /usr/lib/<whereeveritfoundit>/mod_suexec.so /usr/lib/apache2/.

    Otherwise you maybe check your apache2 installation.

    I'm not using SuSE, so I don't know which apache2 packages are installed. Try to find it out with rpm -qa | grep apache2

    Hope this maybe helped
     
  10. viperxx

    viperxx Guest

    0
     
    That might fix it for the suse user. I checked mine and since I am using Fedora Core 1, and its in httpd instead of apache2, mine doesn't have that problem. I don't have any error messages in the auto update log in /tmp/

    also:

    [root@localhost modules]# locate mod_suexec.so
    /usr/lib/httpd/modules/mod_suexec.so
    [root@localhost modules]#

    Although, I just noticed that instead of it saying [root@excalibur-hosting] like it did before the updates, it now says localhost?
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Because I like having the real disc(s) and stuff. Although I have mirrored the entire CentOS to one of my servers but still crave having a 'real' disc (did I mention I'm a bit mental?) LOL just kidding
     
  12. jahsh420

    jahsh420 Guest

    0
     
    anybody find the fix for this on Fedora Core 1:

    The file auth.php3 is part of Plesk distribution. It cannot be run outside of Plesk environment.
     
  13. JamesB

    JamesB Guest

    0
     
    Is this a VPS? If so, check /proc/user_beancounters. You are likely over your shmpages or other limit(s). Setting the shmpages to 12000:12000 and restarting Plesk seems to correct the issue. You may need to bug your host if you don't have access to the hardware node. If this isn't a VPS I have no clue :)
     
  14. Mirco@

    Mirco@ Basic Pleskian

    24
    53%
    Joined:
    Aug 1, 2001
    Messages:
    43
    Likes Received:
    0
    Adding the following to your /usr/local/psa/admin/conf/php.ini should also do the trick:

    [eaccelerator]
    eaccelerator.shm_size=4

    (Don't forget to restart PSA)
     
  15. jahsh420

    jahsh420 Guest

    0
     
    you da man. it was the shmpages. thanks!!:D
     
  16. Stromberg

    Stromberg Guest

    0
     
    I have the same problem. I installed Plesk 8 in a Fedora Core 4 OpenVZ VPS.

    But if I set shmpages to 12000:12000 I get "Cannot allocate memory" opening the Plesk Control Panel or using any commands on console.

    EDIT: I fixed the problem.
     
Loading...