1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk 7.5 and PHP 5

Discussion in 'Plesk for Linux - 8.x and Older' started by Joesimms, Dec 10, 2005.

  1. Joesimms

    Joesimms Guest

    0
     
    Hi

    I would like setup my plesk VDS to run PHP 5.

    I have read that it is not fully supported by Plesk at the moment, and i wondered if this was the case.

    If this is the case, then when it is likely to be fully supported and tested, as there now seems to be alot more php5 based apps appearing on the market, but the ISP and hosting software are lacking the support.

    I have used plesk for a couple of years now and really don't want to change, but i need to lever some of the competitive advantages that these apps offer me, and start to build for the future now!

    Does Plesk publish a roadmap?

    Any help / feedback of people that have tried this configuration or when it will be available and tested would be greatly appreciated.

    Many thanks

    Joe
     
  2. AplosMedia

    AplosMedia Guest

    0
     
    It supports php5 just fine.... but as far as I know your probably going to have to compile it on your own..

    I just updated from 5.0.5 to 5.1.1 (well, actually, im using 5.1.2-dev becuse of pdo issues)

    http://aplosmedia.co/_.php
     
  3. aartiles

    aartiles Guest

    0
     
    Hi, Aplos
    can you explain me how to upgrade?

    I try to compile php5 but don't work :-(

    thanks in advance
     
  4. AplosMedia

    AplosMedia Guest

    0
     
    All you should need is the compile line from my phpinfo. What OS are you running? What errors are you getting?
     
  5. cyrus1u1

    cyrus1u1 Guest

    0
     
    i did compile php4 by myself, it worked fine. i tried php5, but its not getting it..
     
  6. AplosMedia

    AplosMedia Guest

    0
     
    What's happening? What errors are you receiving?

    -- Eric
     
  7. cyrus1u1

    cyrus1u1 Guest

    0
     
    No errors..

    configure, make, make install.. well there was a little error with sapi, but as far as I know you just can remove it in the install_target from the Makefile, and then it should work fine.. i did it for the php4-installation so why shouldn't it work for php 5.1.1?

    do you have to change something else? http.conf or something? because when I just do that what I did, phpinfo just shows me php4, although I really restarted apache..
     
  8. dennysp

    dennysp Guest

    0
     
    I upgraded to php5 on my server tonight. I used the rpms from ART. Had to do some minor changes to php.ini, but nothing you can't figure out.

    http://www.atomicrocketturtle.com

    Thanks
    -d
     
  9. acidbox

    acidbox Guest

    0
     
    can you post your configure line for 5.1.1+?
     
  10. cyrus1u1

    cyrus1u1 Guest

    0
     
    a dummy how to would be nice.. :)
     
Loading...