1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 8.1.1: unable to change Plesk default cert

Discussion in 'Plesk for Linux - 8.x and Older' started by JamesG, Mar 29, 2007.

  1. JamesG

    JamesG Guest

    0
     
    hi,

    I'm unable to change Plesk default cert on my new installed Ubuntu Root-Server with Plesk 8.1.1.
    I get this error:

    ERROR: PleskFatalException
    Up LevelUp Level
    certmng failed: certmng: Error: PRODUCT_ROOT_D not defined

    0: /opt/psa/admin/htdocs/cert/cert.php:225

    thx,
    JamesG
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Make sure that PRODUCT_ROOT_D variable defined in /etc/psa/psa.conf file:

    # cat /etc/psa/psa.conf|grep PRODUCT_ROOT_D

    As you have Debian this PRODUCT_ROOT_D should be /opt/psa/.
     
  3. JamesG

    JamesG Guest

    0
     
    jamesg@server1:/etc/psa$ sudo cat /etc/psa/psa.conf|grep PRODUCT_ROOT_D
    PRODUCT_ROOT_D /opt/psa
    jamesg@server1:/etc/psa$

    thx.
     
  4. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    So, the issue still persists? Did you notice any message in /opt/psa/admin/logs/httpsd_error_log file?
     
  5. spuky

    spuky Guest

    0
     
    Same Problem here

    I have installed on fc5 installed the cert... and selected it as default cert.

    and ist is working on the domain (vhost with the domanname) but not for the controlpanel interface which is on the same domain

    any hints ?????


    edit:
    It seems that it is used as a default cert... because it is used on other vhosts too...

    but > not used for the psa server or where do I configure which cert to use for PSA beside of the default cert
     
  6. JamesG

    JamesG Guest

    0
     
    Hi,

    This problem is still there...
    jamesg@server1:~$ sudo tail /opt/psa/admin/logs/httpsd_error_log
    Check for components installation status
    [Fri Mar 30 19:59:33 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Fri Mar 30 19:59:33 2007] [error] OpenSSL: error:1407609C:SSL routines:func(118):reason(156)
    Checking for installed system packages...done.
    Download file products.inf3: 100% done.
    Download file plesk.inf3: 31%..100% done.
    Download file sitebuilder.inf3: 11%..100% done.
    Download file PSA_8.1.1/plesk-8.1.1-ubt6.10-i386.inf3: 34%..100% done.
    Check for components installation status
    certmng: Error: PRODUCT_ROOT_D not defined

    thx,
    JamesG
     
  7. JamesG

    JamesG Guest

    0
     
    @Dmitry Frantsev: what do you see in my httpsd_error_log?
    Is it a Plesk 8.1.1 bug?

    thx.
     
  8. GARMTECH

    GARMTECH Guest

    0
     
    Same on CentOS

    I have the same on fresh CentOS 4/Plesk 8.1.1. Browser shows "certmng failed: certmng: Error: PRODUCT_ROOT_D not defined".

    Code:
    # cat /etc/psa/psa.conf|grep PRODUCT_ROOT_D
    PRODUCT_ROOT_D /usr/local/psa
    Code:
    # tail /usr/local/psa/admin/logs/httpsd_error_log
    [Sun Apr  1 12:56:16 2007] [notice] SIGHUP received.  Attempting to restart
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    [Sun Apr  1 12:56:16 2007] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7a PHP/5.0.5 configured -- resuming normal operations
    [Sun Apr  1 12:56:16 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
    usermng: PAM Error: BAD PASSWORD: it is based on a dictionary word
    PAM Error End
    [Sun Apr  1 21:43:33 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Sun Apr  1 21:43:33 2007] [error] System: Connection reset by peer (errno: 104)
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    General verification failed
    certmng: Error: PRODUCT_ROOT_D not defined
    
    System error 2: No such file or directory
    certmng: Error: PRODUCT_ROOT_D not defined
    certmng: Error: PRODUCT_ROOT_D not defined
     
  9. Kanagaraj

    Kanagaraj Basic Pleskian

    24
    23%
    Joined:
    May 19, 2003
    Messages:
    60
    Likes Received:
    0
    I have the same error on my CentOs4.2 plesk 8.1.1
     
  10. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Guys, I have Plesk 8.1.1 on FC4 and certificate adding procedure works correctly. I don't have any problems with that. Well, try to check following things:

    * Plesk 8.1.1 installed correctly and there is no packages from previous versions

    * PRODUCT_ROOT_D is defined correctly in /etc/psa/psa.conf

    * directory /usr/local/psa/var/certificates/ exists and have correct ownership and permissions:

    # ls -ld /usr/local/psa/var/certificates/
    dr-x------ 2 root root 4096 Мар 28 00:02 /usr/local/psa/var/certificates/
     
  11. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    In addition, could someone please give me exactly steps how this situation can be reproduced? I tried following cases:

    * Log into Plesk CP as admin -> Server -> Certificates -> Add New Certificate. In section 'Upload certificate as text' insert Private key * and Certificate itself, specify certificate name and click on Send Text.
    I have also tried 'Upload certificate files' section. It looks good.

    The same procedure I used in domain section. But didn't get any errors.
     
  12. Pie'oh'pah

    Pie'oh'pah Basic Pleskian

    23
    23%
    Joined:
    Apr 5, 2007
    Messages:
    27
    Likes Received:
    0
    Same here

    Hi,

    I'm having the same Problem running on:

    CPU AuthenticAMD, AMD Athlon(tm) 64 Processor 3500+
    Betriebssystem Linux 2.6.16.27-061216a
    Plesk-Version psa v8.1.1_build81070322.16 os_SuSE 9.3

    Can't set up Certs, Error is excactly as described above.

    Var is defined as:
    www:/usr/local/psa # cat /etc/psa/psa.conf | grep PRODUCT_ROOT_D
    PRODUCT_ROOT_D /usr/local/psa


    Further, since Update to 8.1.1 I can't open the Reports (Webalizer/AWStats) anymore. Getting Script Errors on Page and it keeps blank. Does anyone have that prob too?

    Appearently it's both bugs, since the problems seem to be not mine alone.

    Any hint would be appreciated

    regards
    - Alex
     
  13. weeteck

    weeteck Guest

    0
     
    login as admin -> Server -> Certificate -> Select a cert [Checkbox] -> Setup

    ERROR: PleskFatalException

    certmng failed: certmng: Error: PRODUCT_ROOT_D not defined

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/htdocs/cert/cert.php:225

    CentOS 4.4
    Plesk 8.1.1


     
  14. JamesG

    JamesG Guest

    0
     
    Steps:
    login as admin -> Server -> Certificate -> Select a cert [Checkbox] -> Setup

    ERROR: PleskFatalException
    Up LevelUp Level
    certmng failed: certmng: Error: PRODUCT_ROOT_D not defined

    0: /opt/psa/admin/htdocs/cert/cert.php:225

    thx,
    JamesG
     
  15. Pie'oh'pah

    Pie'oh'pah Basic Pleskian

    23
    23%
    Joined:
    Apr 5, 2007
    Messages:
    27
    Likes Received:
    0
  16. Hal9000

    Hal9000 Guest

    0
     
    any solutions to this problem?
    clean install of 8.1.1 on a debian 3.1 system, same problem here :(
    hal
     
  17. weeteck

    weeteck Guest

    0
     
    This is not the first time Plesk has major errors with their system software and no proper support is provided.

    First is the migration from 7.0 -> 7.5 Reloaded was a major TRASH

    Plan to migrate soon :mad:

    Very bad after sales customer service

    Plesk are you listening?
     
  18. Pie'oh'pah

    Pie'oh'pah Basic Pleskian

    23
    23%
    Joined:
    Apr 5, 2007
    Messages:
    27
    Likes Received:
    0
    Agreed

    I wonder if there is a Beta-Team except us...

    -Pie
     
  19. wavedave

    wavedave Guest

    0
     
    I'm running the same setup (CentOS 4.4 + Plesk 8.1.1) and reproduced this error, exactly.
     
  20. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Guys, thank's for this information. I have already passed this request to SWsoft's developers. Let's wait their reply. I hope this situation will be resolved soon.
     
Loading...