• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk 8.2.1: Backup and restore failed

I

Ilandor

Guest
Using 8.2.1, just as with previous versions of the PMM any backup/restore of a domain will fail with permission denied errors.

Code:
Traceback (most recent call last):
File "/usr/local/psa/admin/share/supervisor/processor.py", line 116, in doActivityRunner
newState = self.doActivity()
File "/usr/local/psa/admin/share/supervisor/processor.py", line 817, in doActivity
cmd.spawn(os.environ.has_key("PLESKRESTORE_MODE"))
File "/usr/local/psa/admin/lib/python/subproc.py", line 238, in spawn
proc.run()
File "/usr/local/psa/admin/lib/python/subproc.py", line 193, in run
BaseSubprocess.run(self)
File "/usr/local/psa/admin/lib/python/subproc.py", line 177, in run
self.wait()
File "/usr/local/psa/admin/lib/python/subproc.py", line 197, in wait
BaseSubprocess.wait(self)
File "/usr/local/psa/admin/lib/python/subproc.py", line 187, in wait
raise NonzeroExitException(self, os.WEXITSTATUS(status))
NonzeroExitException: was finished with exit code 1

Below is part of the log from just one of the permission denied instances and is only a fraction of the log.

Code:
[09:56:39|INFO: 6906:p.log] HTTP status code is: 403
[09:56:39|INFO: 6906:p.log] HTTP response: <cli><failure>Permission denied.</failure></cli>
[09:56:39|INFO: 6906:p.log] ++ database_user database user
[09:56:39|INFO: 6906:p.log] ++ database database
[09:56:39|INFO: 6906:p.log] => example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] => ns.example.com.(A)ns.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ ns.example.com.(A)ns.example.com. dns record
[09:56:39|INFO: 6906:p.log] => example.com.(A)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(A)example.com. dns record
[09:56:39|INFO: 6906:p.log] => webmail.example.com.(A)webmail.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ webmail.example.com.(A)webmail.example.com. dns record
[09:56:39|INFO: 6906:p.log] => example.com.(MX)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(MX)example.com. dns record
[09:56:39|INFO: 6906:p.log] => mail.example.com.(A)mail.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ mail.example.com.(A)mail.example.com. dns record
[09:56:39|INFO: 6906:p.log] => ftp.example.com.(CNAME)ftp.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ ftp.example.com.(CNAME)ftp.example.com. dns record
[09:56:39|INFO: 6906:p.log] => mx-a.example.com.(A)mx-a.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ mx-a.example.com.(A)mx-a.example.com. dns record
[09:56:39|INFO: 6906:p.log] => example.com.(MX)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(MX)example.com. dns record
[09:56:39|INFO: 6906:p.log] => ns2.example.com.(A)ns2.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ ns2.example.com.(A)ns2.example.com. dns record
[09:56:39|INFO: 6906:p.log] => example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] => example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ example.com.(NS)example.com. dns record
[09:56:39|INFO: 6906:p.log] => ns3.example.com.(A)ns3.example.com. dns record
[09:56:39|INFO: 6906:p.log] ++ ns3.example.com.(A)ns3.example.com. dns record
[09:56:39|INFO: 6906:p.log] Request is ready for: PLESK_SUID=username LANG=en_US.UTF-8 ALLOW_WEAK_PASSWORDS= /usr/local/psa/admin/plib/api-cli/dns.php '--set' 'example.com' '-list' 'NS,,ns.example.com.;A,ns,xxx.yyy.zzz.aaa;A,,xxx.yyy.zzz.aaa;A,webmail,xxx.yyy.zzz.aaa;MX,,mail.example.com.,10;A,mail,xxx.yyy.zzz.aaa;CNAME,ftp,example.com.;A,mx-a,xxx.yyy.zzz.aaa;MX,,mx-a.example.com.,25;A,ns2,xxx.yyy.zzz.aaa;NS,,ns2.example.com.;NS,,ns3.example.com.;A,ns3,xxx.yyy.zzz.aaa;'
[09:56:39|INFO: 6906:p.log] Request string: ARG[0]=dns&ARG[1]=--set&ARG[2]=example.com&ARG[3]=-list&ARG[4]=NS,,ns.example.com.;A,ns,xxx.yyy.zzz.aaa;A,,xxx.yyy.zzz.aaa;A,webmail,xxx.yyy.zzz.aaa;MX,,mail.example.com.,10;A,mail,xxx.yyy.zzz.aaa;CNAME,ftp,example.com.;A,mx-a,xxx.yyy.zzz.aaa;MX,,mx-a.example.com.,25;A,ns2,xxx.yyy.zzz.aaa;NS,,ns2.example.com.;NS,,ns3.example.com.;A,ns3,xxx.yyy.zzz.aaa;&ENV[ALLOW_WEAK_PASSWORDS]=&ENV[LANG]=en_US.UTF-8&ENV[PLESK_SUID]=username&STDIN=
[09:56:39|INFO: 6906:p.log] HTTP status code is: 403
[09:56:39|INFO: 6906:p.log] HTTP response: <cli><failure>Unable to perform DNS 'set' operation: Permission denied.</failure></cli>

[09:56:39|INFO: 6906:p.log] ExecCliGate::PermissionDenied: Permission denied: Unable to perform DNS 'set' operation: Permission denied. [:7512052]
[09:56:39|INFO: 6906:p.log] DNS zone deployment was failed
 
really hard to say what can be the problem. Probably it's better to contact swsoft support, they will help you (you should have the support contract with them).
 
Back
Top