1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 8.4 -> 8.6: Websites stop working

Discussion in 'Plesk for Windows - 8.x and Older' started by progmatik, Aug 2, 2008.

  1. progmatik

    progmatik Guest

    0
     
    Please Help Me!

    All my website stopped working. I get "Service Unavailable", but FTP and Email are still working.

    Please Advise ASAP.
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please check permissions of 3rd party extensions in IIS.
     
  3. progmatik

    progmatik Guest

    0
     
    how do I do that?!
     
  4. progmatik

    progmatik Guest

    0
     
    All Unknown CGI Extensions: Prohibited
    Allunknown ISAPI Extensions Prohibited
    Active Server Pages: Prohibited
    ASP.NET v1.1.4322: Allowed
    ASP.NET v2.0.50727: Allowed
    FastCGI Handler: Allowed
    FrontPage Server Extensions: Allowed
    Frontpage Server Extension 2002: Allowed
    Internet Data Connector: Prohibited
    ISAPI_Rewrite3: Allowed
    Perl Extensions: Allowed
    PHP Extensions: Allowed
    PHP5 Extension: Allowed
    Plesk Extensions: Allowed
    Python Extensions: Allowed
    Server Side Includes: Prohibited
    WebDAV: Prohibited
     
  5. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please repair permissions as the following

    1. run %plesk_bin%\Reconfigurator
    2. select Check component and folder permissions
    3. press Browse button
    4. choose ISAPI_Rewrite3 installation folder
    5. press Check button

    Probably you will need to restart IIS.
     
  6. progmatik

    progmatik Guest

    0
     
    Did all that and still the same.

    But I finally found out that ISAPI_Rewrite http filter was the cause. Worked fine before the upgrade. I uninstalled it and re-installed it and it now works.

    Thanks anyways.
     
  7. NeuroPsyche

    NeuroPsyche Regular Pleskian

    26
    23%
    Joined:
    Nov 22, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Pennsylvania, USA
    Hiya Progmatik...
    how'd you find out that it was the isapi_rewrite? Can you give some more info?
    This happened to me in the past and I had to call upon Great Swsoft for help. After days
    of explaining it, they fixed it, but never gave me any explaination of the reason.

    I've had so many problems with Plesk this year that I'm just totally fed up with it.
    I truly think the only way to keep Plesk CP / Sitebuilder stable is to be a software writer, know C++, or
    something.
     
  8. SteveDude

    SteveDude Guest

    0
     
    First, where is the ISAPI_Rewrite3?

    Also, how do you uninstall it and reinstall it? I having the same problem with websites. Everything else works, FTP, etc... and it only started after the 8.6 upgade.
     
  9. SteveDude

    SteveDude Guest

    0
     
    ...the other problem I ran into with 8.6, after installing some COM componets I was using would no longer work (Persist Upload and JPEG). I had to manually change the permission settings back to what they should of been
     
  10. AMudie

    AMudie Guest

    0
     
    *bump*

    same issue

    --

    Upgrade from 8.4 to 8.6

    After upgrade, websites display ' Service Unavailable '

    FTP & EMail work fine

    --
     
  11. flitzender_elch

    flitzender_elch Guest

    0
     
    Hy, we have the same problem.

    Where i found the isapi_rewrite Folder?
     
  12. flitzender_elch

    flitzender_elch Guest

    0
     
    We have the same Problem, all Sites show "Service unavaible" when i reset the iis (iisreset.exe)
    the sites work fine for a few minutes and then the failure come back again.

    I search the full server of files for isapi_rewrite (httpd.ini, isapi_rewrite) and i don't found any isapi_rewrite files..

    Any Ideas?
     
  13. SteveDude

    SteveDude Guest

    0
     
    Some File and Folder permissions are getting changed when the update is done. It required me to manually change permissions to the isapi dll as well as all other COM objects I was using. Support told me that nothing was wrong with Plesk and permissions are only set by Plesks Security policies. If that is the case then they must of changed the security policies, as even running the reconfigurator will mess things up again. Never an issue in 8.4 or prior versions. I should of done a container backup before the update, and I would of forgot about the 8.6 update.
     
  14. SteveDude

    SteveDude Guest

    0
     
    ...it also screwed up some permission settings on a File Maker database I was using, so it looks like anything that is using some custom(non-standard) objects/drivers are getting messed up pretty could.
     
  15. MADsserver

    MADsserver New Pleskian

    24
    23%
    Joined:
    Mar 31, 2006
    Messages:
    16
    Likes Received:
    0
    If you run the instal (msi) as default than this is the path:
    C:\program files\helicon\ISAPI_Rewrite3

    If you want to uninstal ISAPI_Rewrite3 you can do that in configuration "software"
     
Loading...