1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 8 and Typo3

Discussion in 'Plesk for Linux - 8.x and Older' started by Dawn, May 8, 2006.

  1. Dawn

    Dawn Guest

    0
     
    Hi,

    I tried to install Typo3 4.0 together with plesk 8. There isn't any very good documentation for that and I don't know what rights user/usergroups do I have to set....

    Is there anybody out there who managed to install Typo3 on a Plesk 8 server?

    Greets and thanks,
    Dawn
     
  2. Lars@

    Lars@ Guest

    0
     
    I did it but dumped it after some days.

    I dumped Plesk and now use Confixx with Typo3 :)

    Try Typo3 Installation and Upgrading (doc_inst_upgr) this worked for me.

    Lars
     
  3. Dawn

    Dawn Guest

    0
     
    *grin* I have to laught a litte bit about your footer... ;)

    But back to the topic: I read this documentation but it wasn't very usefull for me... I gave it up with it and used the INSTALL.TXT of the Source-TGZ File. But I can't find any detailed descriptions about the permissions...

    Which user/group did you take as owner for the source-directory... and which usere/group did you take as owner for the dummy-directory...? Which permissions did you set exept the descriptions which are in the INSTALL.TXT described?
     
  4. Lars@

    Lars@ Guest

    0
     
    Don't know anymore. But there are some Typo3 forums with install questions.

    Or you use the
    installer script from
    http://www.typo3-installer.de/

    Lars
     
  5. Lars@

    Lars@ Guest

    0
     
  6. Dawn

    Dawn Guest

    0
     
    Thanks for the link :)

    I got it to run but I had to chown the files/directories to root:www-data. And thats my problem...

    I don't understand it. I tought su_php makes it possible that all php-files are executed under its owner/ownergroup. So I can't get why I have to chown them to www-data. It doesn't run with a chown to [ftpuser] psacln which is the standard I thought...

    Can you explain me whats my fault?

    Greets and thanks anyway,
    Andy
     
  7. Lars@

    Lars@ Guest

    0
     
    chown = change owner
    chmod = change mode

    1) I suggest you delete all the typo3 files and directories (typo3-xxxx_src+dummy-website)
    2) login as "domainowner" to a shell or "su domainowner" to work as the owner of your website (REMEMBER: avoid working as root!)
    3) use "wget" to download the typo3 src and dummy-website
    4) untar both archives as discribed in the tutorial
    5) access your installation via webbrowser and start setting up the configuration

    For the permissions
    use
    Code:
    chmod 666 myspecialfile.php
    or
    Code:
    chmod -R 666 mydirectory
    The 666 is :
    read & write for "owner" (first 6)
    read & write for "group" (second 6)
    read & write for "others" (third 6)

    the "-R" is for recursive

    for more information see Doctor Google or
    chmod tutorial
    chmod "try & error" simulator

    Lars
     
Loading...