1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 9.2.3 Linux (FC5) PHP 5.1.6 to 5.2.x

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by MarkF, Nov 8, 2009.

  1. MarkF

    MarkF Guest

    0
     
    Hi,

    I would like to know if upgrading from PHP 5.1.6 to PHP 5.2.x would be safe on a production server running FC5 and Plesk 9.2.3.

    If I were to simply upgrade the RPMs to PHP 5.2 would this be ok?

    Advice much appreciated, thanks.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,546
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Yes it can be safely upgraded. With yum for example or just find all php related packages and install updates with 'rpm -Uvh php*.rpm'
     
  3. ndL

    ndL Guest

    0
     
    please provide commands and whole HOW TO do it?

    also please provide links for 'maybe' needed RPM files if the first one option wont work someway
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,546
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    You can find php related packages with

    for example, then go to ftp://ftp.pbone.net/mirror/rpms.famillecollet.com/fedora/5/remi/i386/ find packages for FC5 there, download and install it with

    Not that it is just common way and some additional packages can be installed due to dependences resolving, etc.
     
Loading...