• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Question Plesk after Failed Upgrade to Onyx running again but

k4ci

New Pleskian
Hi ,

after a problem during Update to Odin my Plesk 12.5 ist running again, but there is still something wrong with installation, so i cant install regular 12.5 Updates. Need Help Big thx!!



Code:
Downloading file PSA_12.5.30/examiners/panel_preupgrade_checker.php: 0%
Downloading file PSA_12.5.30/examiners/panel_preupgrade_checker.php: 100% was finished.
Downloading file PSA_12.5.30/examiners/php_launcher.sh: 0%
Downloading file PSA_12.5.30/examiners/php_launcher.sh: 100% was finished.
Checking whether the package dependencies are resolved.
E: Unable to correct problems, you have held broken packages.
---X--- `apt-get` output ---------------------
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 psa-courier-imap : Depends: plesk-base (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed
                   Depends: psa (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed
 psa-horde : Depends: plesk-base (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed
            Depends: psa (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed
            Depends: plesk-web-hosting (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed
 psa-proftpd : Depends: plesk-base (>= 17.0.17) but 12.5.30-debian7.0.build1205150826.19 is to be installed

---------------------- `apt-get` output ---X---
Collecting error details into the log file...

ERROR: Installation will not continue
 
Looks like uncompleted upgrade to Plesk Onyx 17. You can't downgrade to 12.5 version if Plesk Onyx packages are even partially installed.
Try to run

# plesk installer --select-release-current --reinstall-patch --upgrade-installed-components
# plesk repair installation
 
Back
Top