• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk and failover between two systems (same IP configured on two servers)

Thomas Becker

Basic Pleskian
Hello,
I have a simple problem but I do not know how to fix it.
I have two systems with Plesk and Postfix on CentOS 6. On both systems there is the same domain and IP configured:

System A:
Customer with Domain customer.com and IP 11.22.33.44

System B (failover):
Customer with Domain customer.com and IP 11.22.33.44
Mail service and DNS switched off for customer.com in Plesk

This is because of the case of a server failure. In such case we can simply switch the routing of the IP 11.22.33.44 from System A to System B and the website customer.com is available again.

The problem is that Postfix on System B seems to reject mails from System A to any domain on System B. In mail log on System A there is something like "service not available". This is default behavior of Plesks Postfix integration and the anti-spam mechanisms if a system is not authorized to send mails.
When I remove the IP 11.22.33.44 from System B in Plesk (Tools & Settings --> IP Addresses), the mails are delivered.

Plesk seems to write the IP 11.22.33.44 in some config files but which one?
If I know the behavior I can figure out how to solve this.
Any idea how to proceed?

Many Thanks.
 
Last edited:
Back
Top