1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Plesk Login Error

Discussion in 'Plesk for Linux - 8.x and Older' started by mostym, Jul 15, 2005.

  1. mostym

    mostym Guest

    0
     
    Plesk Login Error (solved)

    Hi all. I just tried upgrading to version 7.5.3 from 7.5.2. And now i get this error when trying to access my plesk login screen. Also, my webmail (horde) recieves a imap timeout message. and pop3 is not working as well.

    ERROR: Unable to query: Can't open file: 'misc.InnoDB'. (errno: 1) 0: /usr/local/psa/admin/plib/common_func.php3:177 psaerror(string "Unable to query: Can't open file: 'misc.InnoDB'. (errno: 1)") 1: /usr/local/psa/admin/plib/common_func.php3:365 db_query(string "select param, val from misc") 2: /usr/local/psa/admin/plib/class.Session.php:99 get_param(string "login_timeout") 3: /usr/local/psa/admin/auto_prepend/auth.php3:114 session->session()

    Any suggestions how to fix?
     
  2. hardweb

    hardweb Guest

    0
     
    Your psa database is corrupted. You must restore it from a backup located at /var/lib/psa/.
     
  3. mostym

    mostym Guest

    0
     
    how do i restore it :)?
     
  4. mostym

    mostym Guest

    0
     
    First i would like to thank JLChafardet and agruetz(from Ev1servers IRC) for the help they provided. So, major props to them. Here is what we found.

    I was originally told by EV1servers that i would need to have a system restore done. Which i almost had done.

    Nonetheless, during the upgrade to 7.5.3 it appears that the PSA database was purged of all data, providing the the error above. Fortunately, there were several backups of database located at var/lib/psa/dumps .

    ls -la gave

    -rw------- 1 root root 231 Jul 15 05:14 mysql.daily.dump
    -rw------- 1 root root 53996 Jul 14 05:14 mysql.daily.dump.0.gz
    -rw------- 1 root root 53746 Jul 13 05:14 mysql.daily.dump.1.gz
    -rw------- 1 root root 53643 Jul 12 05:14 mysql.daily.dump.2.gz
    -rw------- 1 root root 53561 Jul 11 05:14 mysql.daily.dump.3.gz
    -rw------- 1 root root 53590 Jul 10 05:14 mysql.daily.dump.4.gz
    -rw------- 1 root root 53051 Jul 9 05:14 mysql.daily.dump.5.gz
    -rw------- 1 root root 53172 Jul 8 05:14 mysql.daily.dump.6.gz
    -rw------- 1 root root 53156 Jul 7 05:14 mysql.daily.dump.7.gz
    -rw------- 1 root root 53124 Jul 6 05:14 mysql.daily.dump.8.gz
    -rw------- 1 root root 55257 Jul 15 20:25 mysql.preupgrade.dump.gz

    if you look at july 15 the db size is 231, a far cry from 53996 from the previous day.

    We took the July 14 file, gunziped and inserted tables back to the psa database: syntax is:

    mysql -u <username> --password="password" -h <localhost> < filethatcontainssql

    When we first ran this, it did not work, because some of the tables already existed in the current psa db file. What you need to do is to rename the current psa db to psa.old, then run the mysql command again. The psa and all other databases are located in var/lib/mysql

    After that download the plesk update extract the rpms, goto the base folder then run rpm -Uhv --force *rpm

    If your password does not work when you try to login to the plesk interface, then just /sbin/services psa stop all then /sbin/services psa start all

    One last thing we needed to do was to update the vhosts files to get the global sub domain webmail.domain.com to be recognized. All of my domains were redirecting back to my main domain. But after i ran
    /usr/local/psa/admin/sbin/websrvmng -a -v

    Everything was back to normal, and running smooth :)

    I hope this helps others out.

    Matthew

    thanks hardweb for pointing me to the right direction.
     
  5. RLBII

    RLBII Guest

    0
     
    I have the exact same problem (but not after and upgrade, it just happend when I tried to login to PSA tonight).

    But when I try and revert the backup file I get the error:

    I'm pulling my hair out over this one. Any help please?
     
  6. hardweb

    hardweb Guest

    0
     
    Delete the BackupTasks table first and then restore from the sql file the table.
     
  7. RLBII

    RLBII Guest

    0
     
    The new /var/lib/mysql/psa directory is completly empty when I get this error.

    I also made sure the permissions and owner on the directory are correct.

    Any other ideas?

    Thanks for trying to help!
     
Loading...