1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk suexec

Discussion in 'Plesk for Linux - 8.x and Older' started by Gorgon@, May 19, 2005.

  1. Gorgon@

    Gorgon@ Guest

    0
     
    Anyone know what the settings are for the Plesk version of suexec? The -V switch does not work for the plesk version.

    I'm trying to debug what looks like a umask issue and it would help if I knew the default umask in suexec (if any).

    Thanks,
    mikeS
     
  2. Gorgon@

    Gorgon@ Guest

    0
     
    I got an answer from sw-soft. The plesk version of suexec is not compiled with a umask setting. So it is possible to set a default umask in the apache startup file. Exactly how you do this will depend on your flavor or Linux/UNIX.

    M
     
  3. WaDavid

    WaDavid Guest

    0
     
    I have tried the umask setting in the apachectl start script and it made no difference =/
     
  4. Gorgon@

    Gorgon@ Guest

    0
     
    Hi WaDavid,

    I have found that with suexec in general the umask setting is a pain in the !#$. When possible, try to set the umask in the script itself. In cases where that is not possible, I sometimes setup a cronjob to correct file permissions. Yes it's a major work around but it does work. :)

    Hope that helps
     
Loading...