1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Won't Allow Me To Assign a New IP to a Domain

Discussion in 'Plesk 9.x for Windows Suggestions and Feedback' started by Michael Legg, Jul 20, 2010.

  1. Michael Legg

    Michael Legg Guest

    0
     
    I need to allocate a domain an exclusive IP in order to install an SSL cert.

    I've added the new IP via "Settings" >> "IP Addresses", set it to Exclusive and assigned it to the correct Client.

    But when I go to [domain name] >> "Web Hosting Settings" the new IP doesn't appear in the drop down list.

    What do I have to do to make Plesk let me use this IP?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Can you see this exclusive IP in Client's IP addresses?
     
  3. Michael Legg

    Michael Legg Guest

    0
     
    Yes I could, but I found away around the problem - I unassigned it from the client and then Plesk let me assign it to the domain.

    So the IP appears to be available to all clients, but that's OK because it's already assigned and they won't be able to use it.
     
  4. Michael Legg

    Michael Legg Guest

    0
     
    The problem now it that the site won't work.

    It just displays the error -

    HTTP Error 500.19 - Internal Server Error
    The requested page cannot be accessed because the related configuration data for the page is invalid.
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
  6. Michael Legg

    Michael Legg Guest

    0
     
    I manually applied permissions for IUSR and IWPD users and it appears to be working again now.

    Why would changing a sites IP address have any effect on file permissions?
     
  7. Michael Legg

    Michael Legg Guest

    0
     
    Now FTP doesn't work. "Home Directory Inaccessible"

    I ran websrvmng --reconfigure-vhost --vhost-name=domain.com but it didn't fix anything.
     
  8. Michael Legg

    Michael Legg Guest

    0
     
    Found the answer here - http://kb.odin.com/549

    I would have thought that any domain or IP that pointed to the server could be used as the FTP hostname ... apparently I was wrong. You must use the exact IP or domain of the account to which you are trying to connect.
     
Loading...