1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk8 doesn't recognize Perl 5.8.8 install on FreeBSD 6.0

Discussion in 'Plesk for Linux - 8.x and Older' started by whammond, Oct 18, 2006.

  1. whammond

    whammond Guest

    0
     
    The install program requires Perl 5.8.8. FreeBSD 6.0 install 5.8.7.
    After installing Perl 5.8.8 (no errors).
    the PSA install script still doesn't see Perl 5.8.8.
    What do I need to do next...?
     
  2. CruzMark

    CruzMark Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2006
    Messages:
    84
    Likes Received:
    0
    You probably have both 5.8.7 and 5.8.8 installed.

    Do a perl -v and see what you get.

    De-install perl5.8.7 (which, I believe, isn't installed by default, but is the version in the ports collection, so something else probably installed it).

    You should be able to do this using "pkg_delete perl-5.8.7"

    Then, update your ports tree using cvsup (I usually install cvsup-without-gui via a pkg_add to the FreeBSD ftp site).

    Now, install perl-5.8.8 from the ports collection.

    I've found that if you don't install 5.8.8 from the ports collection and try to do it from source, Plesk has problems finding files it needs.

    Oh, and if it were me (but I'm anal), I'd blow the entire machine out and start from scratch. And I'd do the following:

    Install FreeBSD 6.0
    Rebuild Kernel
    grab cvsup-without-gui from packages.
    update ports collection
    install perl-5.8.8
    install latest stable openssl from ports
    install whatever else you want
    install Plesk.

    But that's me.
     
  3. whammond

    whammond Guest

    0
     
    Anal is good....

    First, thank you for responding.

    More important, thank you particulary for taking the time to lay out the steps, that is all too rare.

    It worked perfectly, the server is up and running.

    One mistake I made, you are right that Perl 5.8.7 doesn't automatically install, but I was installing Mozilla with installed Perl as a dependency.
     
Loading...