1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

pleskbackup does not backup mail and files

Discussion in 'Plesk for Linux - 8.x and Older' started by albl, Apr 13, 2006.

  1. albl

    albl Guest

    0
     
    Hi All,

    I upgraded to plesk 8 from 7.5.4 today, all went well, however pleskbackup does not save mailboxes and domain files as it used to. The resulting backup file for a 1.7 GB domain is mere 5 KB with domain data only.

    I tried both online and command line options with --all, --domains --clients with the same result.

    Does anyone else have this problem?

    Regards,
    Alex
     
  2. albl

    albl Guest

    0
     
    I looked at the backup file and it seems that backup fails in the binary attachment encoding phase:

    ./pleskbackup --domains ~/back -list ~/domains -verbose

    it ends at name="" no encoded data followes.

    when I do
    ./pleskbackup --all ~/back -verbose
    it ends similarly but instead of the beginning of mbox data I see beginning of hosting data (cgi folder)

    it now ends at
    name="" and no encoded data again

    what is interesting that the dump contains some encoded data like autoresponder messages inside XML tags but seems to fail adding attachments outside of XML.

    Is there a way fo turning debug messages as -verbose is of no help.

    Thanks for your support.
     
  3. colossus@

    colossus@ Guest

    0
     
    I recently contacted swsoft about that matter and Mr. Kalmykov sent me three rpms via scp for to execute .. afterwards now everything works fine, at least the backups work again and I am trying to get the update to work now as well.
     
  4. 0031

    0031 Guest

    0
     
    There are updates for Backup Manager on Plesk autoupdater. This issue is resolved in updates.
     
  5. albl

    albl Guest

    0
     
    Thanks, downloading now.
    I actually traced the error down to a missing @INC path in PleskX.pl

    was fixed by setting this in the shell:

    PERL5LIB=/usr/local/psa/PMM/agents/shared; export PERL5LIB

    Hopefully plesk updater will do that for me.
     
  6. albl

    albl Guest

    0
     
    today's update in autoupdater fixed the backup issue
     
  7. albl

    albl Guest

    0
     
    I found that I need to run pleskbackup with "nice 19" to reduce server load and allow other services run normally.

    What I am missing in the new pleskbackup is --skip-domains feature, which prevents me form running it with --all option, it was very useful in psabackup, and if plesk developers read this, please add it.

    Thanks,
    Alex
     
Loading...