• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

PleskFataException… unable to connect to database

Bernhard

New Pleskian
Hello *,

we are using a V-Server (Ubuntu Linux) with Plesk 12.x and MySQL database.

After a DB access incident we changed the DB admin password… since this moment Plesk isn't working, it shows the message:

ERROR: PleskFatalException: Unable to connect to database: saved admin password is incorrect. (auth.php:149).

With cat /etc/psa/.psa.shadow we got the old password back, stopped the DB, restarted MySQL in safe mode with mysqld_safe --skip-grant-tables & …. but we can't log on to the DB with mysql -uadmin.

At this point we are a bit lost, now.

Is there any idea how we can set the Plesk password to the initial value?

Any advice is highly welcome,
thanks in advance

Bernhard
 
There a bunch of related KB articles about this issue. Have you tried to use KB search for phrase "saved admin password is incorrect" for instance?
 
Back
Top