1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PleskMainDBException

Discussion in 'Plesk for Linux - 8.x and Older' started by Jamesj999, Apr 1, 2006.

  1. Jamesj999

    Jamesj999 Guest

    0
     
    PleskMainDBException *SOLVED*

    Hey guys, I did a yum update on the server, which broke httpd (now fixed, was the ionCube problem). But then I stupidly tried to upgrade to plesk 8 when the httpd was still broken. I have tried to do the upgrade again via shell using the script provided, but nothing. I don't really want to remove plesk and install it again, unless that won't remove any of my existing settings...

    Anyway, now I surf to where plesk should be and I get:
    Code:
    ERROR: PleskMainDBException
    MySQL query failed: Invalid default value for 'srv_bandwidth'
    
    0: /usr/local/psa/admin/plib/common_func.php3:229
    	db_query(string 'ALTER TABLE `module_bf1942_servers` MODIFY `rcon_username` varchar(32) CHARACTER SET binary  NOT NULL default ''')
    1: /usr/local/psa/admin/plib/mysql41/mysql41.php:39
    	mysql41_adopt_column(string 'module_bf1942_servers', string 'rcon_username', string 'varchar(32)', string ' NOT NULL default ''', array)
    2: /usr/local/psa/admin/plib/mysql41/mysql41.php:112
    	MySQL41TableUpgrader->_handleColumn(array)
    3: /usr/local/psa/admin/plib/SQLParser.php:99
    	SQLParser->_parseLineInTable(string '  `rcon_username` varchar(32) NOT NULL default '',')
    4: /usr/local/psa/admin/plib/SQLParser.php:45
    	SQLParser::parseLine(string '  `rcon_username` varchar(32) NOT NULL default '',', integer '4')
    5: :
    	array_walk(array, array)
    6: /usr/local/psa/admin/plib/SQLParser.php:25
    	SQLParser->getArray(array)
    7: /usr/local/psa/admin/plib/mysql41/mysql41.php:67
    	mysql41_adopt_table(string 'module_bf1942_servers', array, string 'utf8', string 'utf8_general_ci')
    8: /usr/local/psa/admin/plib/mysql41/mysql41.php:29
    	mysql41_adopt_database(array, string 'utf8', string 'utf8_general_ci')
    9: /usr/local/psa/admin/plib/mysql41/MySQL41PSADBUpgrader.php:47
    	MySQL41PSADBUpgrader->run()
    10: /usr/local/psa/admin/plib/mysql41/mysql41_psa.php:28
    	mysql41_adopt_psa_database(string 'php://stderr', boolean  false)
    11: /usr/local/psa/admin/auto_prepend/auth.php3:88
    
    Any ideas? Thanks in advance :)
     
  2. otsego

    otsego Guest

    0
     
  3. Jamesj999

    Jamesj999 Guest

    0
     
    Omg, thanks mate :)

    Was searching for a post like that in the forums, but couldn't find it!

    Thanks so much, works fine now :)
     
Loading...