1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PMM migration manager crashing server

Discussion in 'Plesk for Linux - 8.x and Older' started by jens.jensen, Jun 14, 2006.

  1. jens.jensen

    jens.jensen Guest

    0
     
    Hi All,

    I have been using Plesk 6 for years, and have used Plesk 7 briefly, and I never had so many issues that I have with Plesk 8 in just two weeks!

    I just had a new FC4 server provisioned with Plesk 8.0.0. I have been using the migration manager to pull over domains from my old Plesk 6 server. I am having lots of problems (seems like others are too?)

    1. initially, some domains seemed to migrate just fine. The migration process seemed to go normally, the domain, and associated settings seemed to be normal in plesk after migration, but upon further inspection I noticed that the httpdocs folder did not have files from the old httpdocs folders, and that my email boxes for that domain were recreated, but the user mail was not copied to the new server.

    2. I deleted those domains that were not "completely" migrated over, re-initiated the migration process, and now MOST of the domains transferred over 100%.
    However, several domains, when I tried deleting them, the server stopped responding. No ssh, ping, web, etc. I had to get a remote reboot on it. Hosting provider says no console output.
    After a reboot, I would check everything, and try deleting trouble domains again - again crash.

    3. after reboot, I then tried manually removing the domain from psa db:
    remove from domains where name='somedomain.com';
    userdel ftpuser_for_somedomain.com
    rm -rdf /home/httpd/vhosts/somedomain.com
    (edit: also had to delete the dns zonefile, else re-initiating the migration would fail for some errors, cause zonefile still existed on new server, then of course, reload all relevant services...)

    Then I re-initiated migration. This time some domains would migrate over without trouble, but there are still a few domains that will not migrate, and I still cannot delete them from Plesk admin.

    Anybody else having similar troubles?
    Can anybody suggest a way to see why plesk is having these problems?
    Where is the migration log?

    Some observations:
    1. Plesk 8.0.0 seems to be still-in-beta. It was installed with my new server when it was provisioned. I thought I should have gone with a stable/mature version like 7.5.x and now Im kicking myself.
    plesk also crashed my server when intially running the plesk updater. This was an omen!

    2. poor db inconsistency handling. Plesk seems to choke if some of the domain info isnt in the psa db. Average user is stuck. He cant delete the domain, but cant overwrite it. stuck with a non working domain?
    having a user manually edit the psa db because psa can't seem to clean up it's own migration mess is asking for trouble

    3. migration manager. wow, it seems like such a nice feature. It appears to be working good, but whether it fails or not, where is the detailed work log of the migration process? when it does fail for a ny domain, it outputs some error text in the web admin page, but still seems to "partially" keep the domain it was having errors from. where is the option to trash a domain that did not complete migration successfully, when the migration error occurs??!

    Plesk nightmares #408,
    Jens
     
  2. artm

    artm Guest

    0
     
    I'm a Plesk 6 man too.

    I'm seeing lots of bugs trying to migrate sites out of Plesk 6 to Plesk 8.

    One such is :

    if "mail to nonexistent user" is set to a mail account in Plesk 6, then when the site is migrated to Plesk 8 the catch-all is set to "reject"

    A nice "gotcha"!
     
  3. jens.jensen

    jens.jensen Guest

    0
     
    Update. well good news is that I Plesk isnt crashing my server anymore..

    I was able to update to 8.0.1 using autoinstaller (plesk admin web based updater did nothing - it did not warn me or otherwise let me know that it failed due to not enough space for the temp files. Apparently it did not check for temp space and did not warn me when the update failed.)

    I have been trying to migrate some domains over from my Plesk 6 server and now I keep getting the same "untar" error over and over again.

    ----------------
    Details
    Data migration from host iko1.vrrs.com has been completed.

    domain djtitan.net

    Execution of /usr/local/psa/bin/domadmin --update djtitan.net -passwd -status true -stdgui true -skin Silver\ Bullet -country US -zip 75067 -state TX failed with return code 1.
    Stderr is
    Wrong syntax for option's "skin" parameter: unknown skin "Silver Bullet"

    Can not deploy web-content of domain djtitan.net

    Execution of /usr/local/psa/admin/sbin/cid_unpacker /var/psa/PMM/2006-06-17-01.07.42.998822 failed with return code 1.
    Stdin is
    untar

    Can not deploy webstat content of domain djtitan.net

    Execution of /usr/local/psa/admin/sbin/cid_unpacker /var/psa/PMM/2006-06-17-01.07.42.998822 failed with return code 1.
    Stdin is
    untar

    Can not deploy ftpstat content of domain djtitan.net

    Execution of /usr/local/psa/admin/sbin/cid_unpacker /var/psa/PMM/2006-06-17-01.07.42.998822 failed with return code 1.
    Stdin is
    untar
     
Loading...