1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Port 443 redirecting me to Plesk Admin console page

Discussion in 'Plesk for Linux - 8.x and Older' started by memexer, Oct 16, 2005.

  1. memexer

    memexer Guest

    0
     
    When I call https://mydomain.com it redirects me to https://mydomain.com/login.php3 which is the Plesk login page. I tried creating a virtualhost entry in the httpsd.custom.include file but when I do this it still tries to connect to https://mydomain.com/login.php3 except it returns a page not found since I don't have login.php3 in my httpsdocs directory. Where is it pulling this redirection from? I've my document root for my virtual host pointing to /var/www/vhosts/mydomain.com/httpsdocs
    Very desperate to find a solution for this so I'll really appreciate any help given.
    Thank you
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I would first search the Apache config files which are located in several places:

    Plesk Control Panel Apache:
    /usr/local/psa/admin/conf
    (httpsd.conf) - if you edited this file in the past, you should not have. If so, reverse any changes you did and restart Plesk (not just apache). Should have "Listen 8443" in this file, not "Listen 443" which would conflict with the Hosting Apache on SSL.

    Hosting Apache:
    /etc/httpd/conf
    (all files)

    Domain Apache conf files:
    /var/www/vhosts/domain.com/conf
    (httpd.*, vhost.conf, vhost_ssl.conf)

    and

    /var/www/vhosts/domain.com/httpsdocs
    (.htaccess file?)

    More details about your server and any changes, updates, upgrades, may be helpful for others to give you assistance.
     
  3. memexer

    memexer Guest

    0
     
    Thanks for the reply jamesyeeoc.
    I restored my httpsd.conf file with the backup copy I created before tampering with it. It is now what plesk had it to be. I tampered with it to add Listen 443 to fix my initial problem which was that whenever I tried to access https://www.mydomain.com i would get a page cannot be displayed error. So I added the Listen 443 line to the plesk httpsd.conf file (apache httpsd.conf file doesnt have the line) and it opened up port 443 but it redirects me to the plesk admin console whenever I try to access any contents of the ssl directory. I created an httpsd.custom.include file to avoid tampering with Plesk's httpsd.conf. Here I added a virtual host <VirtualHost my_ip_add:443>
    and made sure to specify the DocumentRoot as the httpsdocs directory.
    Of what you told me to look at, I don't have a vhost_ssl.conf file in /var/www/vhosts/domain.com/conf and I created a vhost.conf file while trying to fix the problem before but it didnt help. I moved the contents of the httpsd.custom.include to vhost.conf but it didnt help. I dont have the .htaccess file in my ssl document root directory either.
    Server is a dedicated Linux server running just plesk at the moment. Please let me know where I should elaborate or what other helpful details I could offer.
    Thanks
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The files located in

    /usr/local/psa/admin/conf

    are for the Control Panel's version of Apache. You cannot 'fix' problems with the Hosting version of Apache by modifying any of the files in that directory. Not even by putting your own httpsd.custom.include
    statements. Please put that directory's files back to the way they were originally and remove any additions/changes to files which you made.

    If the normal or Hosting version of Apache is not listening on port 443/SSL, then that is another matter which needs to be addressed by looking at the config files in /etc/httpd/conf and whether your server has mod_ssl installed or not.

    I helped another admin last week, found that his new CentOS 3.3 server did not have mod_ssl installed which prevented Apache from responding to port 443, and awstats from working properly as well.

    To find out, SSH into the server as root and do:

    rpm -q mod_ssl

    If you have it installed, then it will show you what package version. If you do not have it installed, then you would install it by (depending on version of your OS) using yum, up2date, apt-get, or downloading the RPM and manually installing it.
     
  5. memexer

    memexer Guest

    0
     
    Most thankful to you jamesyeeoc for your quick response. I believe I don't have mod_ssl installed, you are right. I can't access the server through SSH at the moment since I'm behind a corporate firewall but I will try your suggestion as soon as I am able to and will reply back whether it works or not. Hopefully this will do it. I shouldn't worry about vhost.conf or vhost_ssl.conf files then should I? I have CentOS 3.5 on the server.
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    No, I would not worry about vhost.conf or vhost_ssl.conf (unless you have modified them while trying to solve this problem).

    As you know, both those files are not normally created for any domain, unless or until some specific need (such as Rewrites) arises for a given domain. No changes to those files would be necessary to enable or disable SSL for a domain.
     
  7. memexer

    memexer Guest

    0
     
    jamesyeeoc, you are golden.
    Installing mod_ssl did the trick. Thank you for your guidance. Truly greatful for all your help.
    Take care.
     
Loading...