1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

postfix localhost.localdomain

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Brujo, Oct 22, 2009.

  1. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
    I report this issue since Version 9 with postfix and still there is this issue with adresses like this when i run the /usr/local/psa/admin/sbin/mchk:

    if a domain has already a mailbox or alias for example with root then the entry in the virtual.db is ok and not wrong, but if a domain has not a mailbox or alias for root, anonymous, postmaster it automatically creates it with the @localhost.localdomain. thats not correct!

    anonymous@domain1.de anonymous@localhost.localdomain
    postmaster@domain1.de postmaster@localhost.localdomain
    root@domain1.de root@localhost.localdomain


    i realy wonder how long it will take until this issue is fixed

    Brujo
     
  2. trialotto

    trialotto Golden Pleskian Plesk Guru

    37
     
    Joined:
    Sep 28, 2009
    Messages:
    1,445
    Likes Received:
    206
    Seems not to be an issue

    It is not an issue: the default anonymous, root and postmaster etc mail addresses are being created as *@<name> with <name> being the serverDomainname (for example, for qmail this is the content of the file /var/qmail/control/me)

    When declaring a mail address on a domain, this is simply a different and new mail address, coexisting with the default anonymous, root etc. addresses.

    You do not want your "issue" fixed... believe me. For a lot of reasons, but primarily for security reasons.

    And it is even not wise to create root@<domainName>.tld, etc mail addresses, since those addresses WILL make your system a spam target in the near future.

    In short, you always have the possibility to create additional root etc. mail addresses on a domain, that COEXIST with the default server mail addresses.
     
  3. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
    Hi trialotto and thanks for answer, but i belive there are several missunderstandings...

    first i talk about postfix, and second for each domain wich has not a mailbox or alias for:
    (root, postmaster, mailer-daemon, anonymous) plesk creates automatically it with @localhost.localdomain. So this means for example i have 50 Domains without a postmaster address it creates for each domain this entry in the virtual.db like:
    and i still dont understand why this should be happen or more secure?

    so if a sender sends a mail to a postmaster@domain1.de he get back:
    this looks for the sender more as a missconfigured mailaccount...

    but if thus account are not automatically created postfix will send back 5.1.1 - recipient address rejected: User unknown in virtual mailbox table which is standard and a normal behavior for me

    but of course I agree it is not wise to have root@ wich will lead to spam
     
  4. trialotto

    trialotto Golden Pleskian Plesk Guru

    37
     
    Joined:
    Sep 28, 2009
    Messages:
    1,445
    Likes Received:
    206
    Although I am not fully into Postfix, it seems that there is some erroneous interpretation. Not only between us, my apologies for that....but also in the interpretation of what happens.

    The creation of those entries in virtual.db in itself is not a bug. What happens is that postfix redirects mail to postmaster@domain<i>.tld to the mail address postmaster@localhost.localdomain.

    I would not like this, by the way, since this is potentially spam entry (if and only if the postmaster addresses are not well protected). I am not sure whether it is a Plesk configuration or a Postfix standard setting.

    Then, if redirecting mail by Postfix, mail cannot be delivered and the root is notified by that (note the security threat of this!).

    Various reasons exist for the mail not being delivered, with two primary categories: configuration issues and compilation issues/bugs in postfix itself.

    My best guess is that the forwarding bug exists in the plesk provided postfix. I believe that this has been an issue and if you did install that version, you are probably encountering that problem.

    To exclude the configuration category, I installed a normal postfix and a plesk provided postfix. Nothing extraordinary arises when looking at the configuration files. But i can be mistaken.

    My advise to you: re-install/update postfix with the autoinstaller (command line!).

    NOTE: it is ironic that you have to install qmail in order to reinstall postfix with the autoinstaller. In my opinion, stay with qmail. At least for the reason that Parallels keeps on patching postfix (as can be seen from the release notes) and it is not very likely to be finished with it.
     
Loading...