1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem installing Plesk 9.5.2 on Debian 5 64 bits

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by LaurentR2D2, Jun 26, 2010.

  1. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    Hello

    I'm trying to install Plesk 9.5.2 on a Debian 5 64 bits and it always fails because of a problem of dependencies.

    E: Broken packages
    ERROR: autoinstaller: Error in execution of DEBIAN_FRONTEND=noninteractive

    ERROR: Impossible d'installer des packages à cause de problèmes de dépendance des packages.
    Les packages n'ont pas tous été installés.
    Veuillez contacter l'assistance technique du produit.

    I've tried to add this to source.list :

    deb http://autoinstall.plesk.com/debian/PSA_9.5.2 lenny all

    and I have opened my firewall for Plesk update. No way. Should I rather install a previous version of Plesk or is there something else I should do ?

    Thank you
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Do you have any useful in /tmp/autoinstaller3.log ?
     
  3. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4
    Here is a link to the log :

    http://dl.dropbox.com/u/51818/autoinstaller3.log

    and I still see psa-installer.lock in /tmp even when the installer have stopped. Debian 5/Lenny 64 bits is a fresh install

    # uname -a
    Linux sd-20213 2.6.32-bpo.4-amd64 #1 SMP Thu Apr 8 10:20:24 UTC 2010 x86_64 GNU/Linux
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    There is following error:
    Try to uncheck tomcat support in autoinstaller menu or try to install sun-java6-jdk before Plesk installation.
     
  5. LaurentR2D2

    LaurentR2D2 Plesk Certified Professional Plesk Certified Professional

    31
    68%
    Joined:
    Aug 6, 2009
    Messages:
    129
    Likes Received:
    4

    It works. I've installed sun-java6-jdk and the problem was due to the fact that non-free section of Debian was not in the source-list.

    Thank you
     
  6. ThiagoL

    ThiagoL Guest

    0
     
    Plesk is already installed

    Plesk is already installed, have any solutions?

    plesk:/Instaladores# apt-get install sun-java6-jdk
    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências
    Lendo informação de estado... Pronto
    sun-java6-jdk já é a versão mais nova.
    sun-java6-jdk configurado para instalar manualmente.
    Você deve querer executar 'apt-get -f install' para corrigí-los:
    Os pacotes a seguir têm dependências desencontradas:
    libpam-plesk: Depende: psa-9.5.3 mas não é instalável
    psa: Depende: psa-locale-base-9.5.2 mas não é instalável
    Depende: plesk-skins-9.5.2 mas não é instalável
    psa-api-rpc: Depende: psa-api (= 9.5.3-debian5.0.build95101022.06) mas 9.5.2-debian5.0.build95100504.17 está para ser instalado
    Depende: psa-9.5.3 mas não é instalável
    psa-backup-manager: Depende: psa-9.5.3 mas não é instalável
    psa-mail-pc-driver: Depende: psa-mail-driver-common mas não é instalável
    psa-miva: Depende: psa-9.5.3 mas não é instalável
    psa-rubyrails-configurator: Depende: psa-9.5.3 mas não é instalável
    psa-spamassassin: Depende: psa-9.5.3 mas não é instalável
    E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
     
  7. ThiagoL

    ThiagoL Guest

    0
     
    plesk:/Instaladores# apt-get install sun-java6-jdk
    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências
    Lendo informação de estado... Pronto
    sun-java6-jdk já é a versão mais nova.
    sun-java6-jdk configurado para instalar manualmente.
    Você deve querer executar 'apt-get -f install' para corrigí-los:
    Os pacotes a seguir têm dependências desencontradas:
    libpam-plesk: Depende: psa-9.5.3 mas não é instalável
    psa: Depende: psa-locale-base-9.5.2 mas não é instalável
    Depende: plesk-skins-9.5.2 mas não é instalável
    psa-api-rpc: Depende: psa-api (= 9.5.3-debian5.0.build95101022.06) mas 9.5.2-debian5.0.build95100504.17 está para ser instalado
    Depende: psa-9.5.3 mas não é instalável
    psa-backup-manager: Depende: psa-9.5.3 mas não é instalável
    psa-mail-pc-driver: Depende: psa-mail-driver-common mas não é instalável
    psa-miva: Depende: psa-9.5.3 mas não é instalável
    psa-rubyrails-configurator: Depende: psa-9.5.3 mas não é instalável
    psa-spamassassin: Depende: psa-9.5.3 mas não é instalável
    E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).

    Plesk is already installed, how can I do I can not uninstall and install tomcat. how can I do? I can not update.
     
Loading...