1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem migrating from Ensim 4.0.3 to Plesk 8.0.1

Discussion in 'Plesk for Linux - 8.x and Older' started by robby, Jul 20, 2006.

  1. robby

    robby Guest

    0
     
    Hello,

    I just tried to migrate a domain from an Ensim Pro 4.0.3 (Linux RHE3) to plesk 8.0.1. Plesk Migration Manager is up to date, and I get this error when trying to import a domain from the Ensim server:

    Failed validation of the document with external DTD /usr/local/psa/PMM/agents/EnsimX/control/EnsimX.dtd. The errors are: Element domain-user content does not follow the DTD, expecting (pinfo , password , domain-user-limit* , domain-user-permission*), got (pinfo ).

    When in the migration manager I use the root account in ensim server to do the operation. The domain in the ensim server is OK, no issues in it.

    I have tried all that I could find in the forums but no go.

    Where can I find the exact reasons why it fails? .. reading the error it seems that PMM can't get some info of the domain from the Ensim server ... so how can I do to provide it? (maybe could be provided manually?)

    Thanks.
     
  2. robby

    robby Guest

    0
     
    anyone ?
     
  3. 0031

    0031 Guest

    0
     
    You better ask SWsoft support to help with it. It's obvious that EnsimX.pl migration agent can't determine password for analogue of Plesk domain-level user in your Ensim configuration. You may look at it in /usr/local/psa/PMM/agents/EnsimX - it's a usual Perl script. Search a 'domain-user' string and see a logic behind it...
     
  4. robby

    robby Guest

    0
     
    anyone can help on this?
     
  5. raygp

    raygp Guest

    0
     
    I found the solution

    I had this same problem while trying to migrate ensim domains to plesk. (ensim 4.0.3 to plesk8.0.1)

    I just want to say that this solution worked for me and I take no responsibility if anything messes up. It takes editing a file to get the migration manager to work.

    MY SOLUTION:
    Edit the file:
    /usr/local/psa/PMM/agents/EnsimX/control/EnsimX.dtd

    Look for the line like this: (line 103 for me)
    <!ELEMENT domain-user (pinfo, password, domain-user-limit*,
    domain-user-permission*)>

    Change it to this:
    <!ELEMENT domain-user (pinfo, password*, domain-user-limit*,
    domain-user-permission*)>

    (Notice the addition of the * after password)

    LOGIC BEHIND THE SOLUTION: (I provide this so that you can make an educated decision as to whether or not you want to try this fix or maybe someone can provide a better fix)
    Well, I couldn't find any help online or in any of these forums.
    I looked at the log files after the failure (no clue)
    I looked at the EnsimX.pl script (no clue)
    I looked at the remote server (ensim server) under the /migration folder (after the failure and keeping temporary files). I found a file called dump.xml and it contained a list of domain-users and one of them did not have a password set (smmsp).
    So I figured that was the problem, smmsp did not have a password set.
    I tried to set a password for smmsp in ensim but it won't let you (maybe someone can figure out how to set password for smmsp)
    I remembered from error that it referred to a EnsimX.dtd and put 2 and 2 together.

    Once the temp files are dumped to the remote server in the /migration folder then it checks dump.xml and verifies it against EnsimX.dtd. It then fails if the requirements are not met. I then figured out that the * in these fields in Ensim.dtd means that the field is optional. So since I couldn't figure out how to set a password for smmsp user I simply made the password field optional for domain-users

    With this information I would like to see if anyone out there can figure out a better fix.
     
Loading...