1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem removing domains from Plesk interface

Discussion in 'Plesk for Windows - 8.x and Older' started by colinjack, Mar 19, 2006.

  1. colinjack

    colinjack Guest

    0
     
    I have a domain that will NOT delete from the Plesk interface. I am running 7.5.6

    "Remove domain" removes the domain from IIS but it is still shown on the Plesk interface (so obviously has not deleted from the Plesk database). Error says

    "Unable to remove domains: problems occurred whilst removing domains: unable to remove hosting:unable to create subdomain manager: unable to create subdomainperformance object: ...etc."

    Obviously it can't find the domain in IIS ('cause it has already deleted it) so what now? Plesk Configurator doesn't fix it.

    I just need to remove it from the Plesk database but need some guidance.

    Anybody frm Plesk able to help?
     
  2. OlegB

    OlegB Guest

    0
     
  3. colinjack

    colinjack Guest

    0
     
    Thanks ... I have already tried all this. I do not want to repair it (although I have done this three times (repairing it) before trying to remove it totally).

    I just want to remove it from the Plesk database. Plesk is removing it from IIS okay but not from itself.

    All I need is instructions on getting into the database and removing that record.

    Thanks

    Colin
     
  4. cybernova

    cybernova Guest

    0
     
    seems like the plesk was not able to remove the subdomain from the IIS or from the backup path
     
  5. colinjack

    colinjack Guest

    0
     
    If you look at the original post, Plesk has no problem deleteing it from IIS :)

    The problem is that it doesn't then delete the record from the Plesk database ... I just need to work out how to chop the record out of the psa database.
     
  6. OlegB

    OlegB Guest

    0
     
    To let Plesk to remove domain or subdomain properly this domain (subdomain) should have proper configuration in the system.
    Also it should be present in IIS.
    Try

    websrvmng.exe --remove-vhost --vhost-name=domain.com
    websrvmng.exe --reconfigure-vhost --vhost-name=domain.com

    this command will reconfigure all subdomains for a domain then you can remove domain or subdomain.
     
  7. colinjack

    colinjack Guest

    0
     
    I did all this and it didn't work. It removes the domain in IIS but doesn't remove it from the PSA database. I eventually used MySQL CLI to remove the necessary problem records. All fine now.
     
  8. adrianrz2000

    adrianrz2000 Guest

    0
     
    I have the same problem and I did all this too and nothing repair the problem.

    Anybody have another idea?

    Thanks

    Adrián
     
  9. sysber

    sysber Basic Pleskian

    23
    57%
    Joined:
    Nov 8, 2005
    Messages:
    41
    Likes Received:
    0
    Hello,

    I am with a similar problem to this informed here for colinjack, when I create a domain it creates the DNS entrances, it creates in mailEnable, more the domain in the IIS does not create, and in the Event Viewer it appears the message:

    Error in the DLL (COM Error 800401F9) at addAppPool(domainproblem.com(domain)(pool), IWPD_190(lada))

    at (WebServerAdapter::addAppPool line 3238)

    at addAppPool(domainproblem.com(domain)(pool), IWPD_190(lada))(WebServerAdapter::addAppPool line 3252)

    at addHosting(domainproblem.com)(WebServerManager::addHosting line 1913)

    at execute console command --reconfigure-vhost(vconsoleapp::start line 128)

    at execute "C:\Program Files\SWsoft\Plesk\/admin/bin/websrvmng" --reconfigure-vhost "--vhost-name=domainproblem.com"(vconsoleapp::run line 138)

    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng.exe

    it would like to know if it has some information on this error so that the domain in the IIS can create.

    I am very grateful for any supplied aid :D

    Best Regards,

    Sysber
     
  10. jhabbley

    jhabbley Guest

    0
     
    I too have experienced this problem before. In my experience, restarting IIS and then running websrvmng usually works. However, this time it seems as though I'm stuck with a domain that has mail, dns, etc... but no actual IIS instance.

    Here's what I get from the EventViewer when I try to run the "fix".

    ---

    Error in the DLL (COM Error 800401F9) at addAppPool(problemdomain.com(domain)(pool), IWPD_201(probUser))
    at (WebServerAdapter::addAppPool line 3236)
    at addAppPool(problemdomain.com(domain)(pool), IWPD_201(probUser))(WebServerAdapter::addAppPool line 3250)
    at addHosting(problemdomain.com)(WebServerManager::addHosting line 1913)
    at execute console command --reconfigure-vhost(vconsoleapp::start line 128)
    at execute websrvmng --reconfigure-vhost --vhost-name=problemdomain.com(vconsoleapp::run line 138)
    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng.exe
     
  11. jhabbley

    jhabbley Guest

    0
     
    The more times I run into this problem and try different solutions to solve the problem, the more I'm convinced that the problem has to do with memory issues.

    Most times, when this error occurs, if I run 'iisreset' before I run the websrvmng command, it works just fine.

    In this case however, it wasn't that easy. I had to stop other services to get the active memory load down, THEN run iisreset, THEN run websrvmng before all of the w3wp.exe processes returned.

    Why is there no solid answer to this? Or some sort of recommended solution? Yeah, yeah, I know... reinstall the OS, right? Pff.
     
Loading...