1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem upgrading to 8.1.0 with updater (3.1.0)

Discussion in 'Plesk for Linux - 8.x and Older' started by ralphschindler, Dec 1, 2006.

  1. ralphschindler

    ralphschindler Guest

    0
     
    Does anyone know how to get past this?


    Pertinent information:

    [root@SMASHER updater]# /usr/local/psa/admin/bin/autoinstaller --version
    Plesk Autoinstaller 3.1.0 (build at 2006-12-01 02:40)

    [root@SMASHER updater]# /usr/local/psa/admin/bin/autoinstaller --select-release-id PLESK_8_1_0 --install-component base
    Checking for installed system packages...done.
    Download file products.inf3: 100% done.
    Download file plesk.inf3: 100% done.
    Download file sitebuilder.inf3: 11%..100% done.
    Download file PSA_8.1.0/plesk-8.1.0-rhel4-i386.inf3: 100% done.
    Check for components installation status
    Reading system installed packages...done.
    Download file build-8.1.0-rhel4-i386.hdr.gz: 54%..100% done.
    Download file update-8.1.0-rhel4-i386.hdr.gz: 28%..100% done.
    Resolve components
    ERROR: Impossible do installation while package psa-hotfix6-8.0.1-rhel4.build80060928.14.i586 is installed in system
    Errors just before:
    - Trying to find direct hardwired dependencies for package psa-8.1.0-rhel4.build81061129.22.i586
    - Check for need upgrade of psa-hotfix6-8.0.1-rhel4.build80060928.14.i586 with upgrade of psa-8.0.1-rhel4.build80060613.20.i586 wich needs to install psa-8.1.0-rhel4.build81061129.22.i586
    - Unresolved dependency: necessary package psa-8.1.0-rhel4.build81061129.22.i586 have older version psa-8.0.1-rhel4.build80060613.20.i586. After upgrade we will have the dependency 'psa = 8.0.1' of package psa-hotfix6-8.0.1-rhel4.build80060928.14.i586 is unresolved, add to removable list psa-hotfix6
    - Find remove mode solution for package psa-hotfix6-8.0.1-rhel4.build80060928.14.i586
     
  2. jeambeam

    jeambeam Guest

    0
     
    I have two successful upgrade for rhel4 i386 and one for rhel4 amd64.
     
  3. ralphschindler

    ralphschindler Guest

    0
     
    Perhaps I fail to see how your comment helps me? This box is not quite a month old and was created from an image that EV1 servers has. That being said, I dont think there is much out of the ordinary about my installation of 8.0.1 How do I fix the dependency issues and get 8.1.0?

    Where do I get RPM's for psa? I do not see a yum repository anywhere online hosted by SWSoft.

    Thanks,
    Ralph
     
  4. jeambeam

    jeambeam Guest

    0
     
    1. As far as I know psa package obsoletes all the psa-hotifx* packages and in your case such package breaks the installation. You can try to remove all psa-hotfix*-8.0.1*.rpm packages, then try to install psa-8.1.0

    2. if you look at EZ templates
    /vz/template/redhat/as4/x86/config/app/plesk8-api/default/repositories
    you see that yum repositories are:
    http://autoinstall.plesk.com/PSA8/dist-rpm-RedHat-el4-i386
    http://autoinstall.plesk.com/PSA8/update-rpm-RedHat-el4-i386
     
Loading...