1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

[problem] Using Migration Manager for 7.0.4 -> 7.5.4 change

Discussion in 'Plesk for Linux - 8.x and Older' started by mousehouse, Nov 9, 2005.

  1. mousehouse

    mousehouse Guest

    0
     
    OK,

    I have two physical servers, one running 7.0.4 hosting a big chunk of our domains and a new server running 7.5.4. I'd like to use the Migration Manager (PMM) to move over all our domains but so far it is barfing on us big time.

    Both machines run FreeBSD (7.0.4 on 4.11, 7.5.4 on 5.4). I moved the Plesk7X.pl script over to the 7.0.4 machine and placed it is /usr/local/psa/PMM.

    What happen is:

    1) I run "./Plesk7X.pl -da=client" it dumps everything correctly.
    2) I move the files to the new machine, including the dump.xml.
    3) I run the migration manager from the Plesk CP.

    It imports a lot, except data that needs to be extracted. The following error is given many times for different directories...

    [error]
    [22:05:36 09.11.2005 | pid 46992]:Executing cat -- '//test.de.private.tar.gz'.?? | tar xvfz - -C '/
    usr/local/psa/home/vhosts/test.de/private'
    [22:05:36 09.11.2005 | pid 46992]:<?xml version="1.0"?>
    <message code="tError_Exec_UtilFailed" severity="error"><context>std::string getCmdOutput(const std:
    :string&amp;)</context><file>deployer/cmd_exec.cpp</file><line>33</line><text>Execution of the follo
    wing utility failed:
    cat -- '//test.de.private.tar.gz'.?? | tar xvfz - -C '/usr/local/psa/home/vhosts/test.de/private'
    The return code was

    The output on STDOUT was:


    The output on STDERR was:
    1</text></message>

    [/error]

    I see this for the httpdocs etc. as well, which means importing is not running properly.

    Any clues?
     
  2. 0031

    0031 Guest

    0
     
    > cat -- '//test.de.private.tar.gz

    It seems like archive storage directory is not set or set wrongly. It should be something like /usr/local/psa/PMM/archives/test*

    You may set it up somewhere on "migrating host preferences" page...
     
  3. mousehouse

    mousehouse Guest

    0
     
    I ended up editing the dump.xml manually for all domains, which turned out to be a nightmare but worked. The paths put into the dump.xml were all borked up.

    After that it worked, except from some email autoresponder stuff, which I don't care about too much.
     
Loading...