1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with migrating from Plesk to Plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by wyrix, Nov 27, 2008.

  1. wyrix

    wyrix Guest

    0
     
    When I try to migrate from my old Plesk server to a new one (both Plesk 8.6), I got some weird errors and I can not find a way to fix them.

    When I look into the mentioned file ("/usr/local/psa/PMM/var/2008-11-27-19.47.00.458426/dump.xml"), I see that there are a lot of "^@" displayed at line 75 (the line of the first error).

    Can anyone tell me how to fix the problem? I really get stuck and this error returns for all clients and domains.

    Best regards,
    Rik Wijnen
     
  2. wyrix

    wyrix Guest

    0
     
    In addition to my first post;

    I can see in the XML that the error at the moment only exists in the tag "mailuser-permission" for the key "multiple-sessions":
    I found that this is a permission for a mailuser for which I can not find any record in the "Permissions" table in the "psa" scheme.

    Maybe this can help to fix the problem...
     
  3. OZyryanov

    OZyryanov Guest

    0
     
    Hello!
    Looks like this strange value is in your psa database.

    Could your check this?

    If you have only one such user, please try change this permission for mail user and the migrate again.

    Thank you.
     
  4. wyrix

    wyrix Guest

    0
     
    Well,

    Whatever domain I select the migration will fail. Always with the same reason (which I mentioned before).
    It does not happen when a domain hasn't got any mail account. But that's not the way it should be, I think?

    Can anyone help me?
     
  5. wyrix

    wyrix Guest

    0
     
    I have been looking for the problem in the database and Plesk.
    I found that I can't select "allow multiple sessions" in the mail preferences. That is, I can select, but it doesn't save when I say it has to. Somehow the value is not stored in the database.
     
  6. wyrix

    wyrix Guest

    0
     
    Jees! What a terrible software for migration! Sorry to say that, but it doesn't work as it should be.

    What I did so far:
    * I made a migration, just the way as it should go. Then Plesk returns an error and I selected "keep the temporary files".
    * Then I removed all "^@" in the dump file.
    * Then I moved all the contents of the latest migration-directory (something like "/usr/local/psa/PMM/var/2008-12-14-11.25.26.647689") to the upper directory (to "/usr/local/psa/PMM/var").
    * Then I started a new migration, but now I select "data import". This way, you can select a failed dump-file to reprocess. But, otherwise as you should think, the "dump.xml" must be in "/usr/local/psa/PMM/var" and not in a directory like "/usr/local/psa/PMM/var/2008-12-14-11.25.26.647689". Bug in Plesk I think?!
    * Now Plesk returns the following errors:

    Why is it so hard to migrate?!

    Can anyone help me? Or tell me an other way to migrate everything?
    I can backup a website and restore it at the other server. But then I need to add all clients again.
    And downloading and uploading a backup-file does take a lot of time. Does anyone know where Plesk stores the backup-files? So that I can copy it directly from the old server and paste it directly on the new server?
     
  7. OZyryanov

    OZyryanov Guest

    0
     
    Very strange problems. Please, contact to support team.
     
  8. wyrix

    wyrix Guest

    0
     
    How can I contact support?
     
  9. wyrix

    wyrix Guest

    0
     
    Can anyone tell me where Plesk should save the value for "Allow multiple sessions", under "Control panel access" when i edit the mail user? It looks like this is the cause of the error...
     
  10. wyrix

    wyrix Guest

    0
     
    Well, I finally did it!

    The problem was that the table "mn_param" had some weird values.
    I executed the folowing sql code to correct them:
    NB: Please view the source of this page for the correct sql query!

    Then, I changed all values for "multiply_login" to "false". Changing them to "true" won't work.
    After that, the migration completed successfully!

    Plesk is a wonderful product, but the errors are terrible. And so is their support!
     
Loading...