1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problem with restore ms sql server 2008 database

Discussion in 'Plesk 11.x for Windows' started by Ehsandamd, Jan 1, 2013.

  1. Ehsandamd

    Ehsandamd New Pleskian

    10
     
    Joined:
    Jan 1, 2013
    Messages:
    1
    Likes Received:
    0
    im using plesk 11.0.9
    i have a problem with restore ms sql server 2008 database after restoring the message
    Error: Unable to creste database user: Database user name is invalid. Only latin letters are allowed in the database user nameerror

    appear ??

    how can i resolve this error

    i created
    database name : rastebazar
    user : rastebazar
    in plesk
     
  2. PeterWell

    PeterWell New Pleskian

    6
     
    Joined:
    Sep 27, 2013
    Messages:
    2
    Likes Received:
    0
    Same here. Any help's appreciated.
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    This is because of the domain's name starts with a number. While creating database user, by default Plesk adds domains name prefix.

    Login to Plesk using "admin" and go to Home>Tools & Settings>Database Servers>Database hosting settings
    Then uncheck "Add user's login name and underscore to the beginning of database names" and "Add user's login name and underscore to the beginning of database user names"
     
  4. hamed23100

    hamed23100 Regular Pleskian

    25
    57%
    Joined:
    Mar 9, 2006
    Messages:
    109
    Likes Received:
    0
    Hi, we unchecked both you said but still we get following error:

    Unable to create database user: Database user name is invalid. Only Latin letters are allowed in the database user name

    Regards,
    Hamed
     
  5. InderS

    InderS Silver Pleskian

    15
    30%
    Joined:
    Apr 17, 2013
    Messages:
    968
    Likes Received:
    1
    Location:
    Nashik
    try to open the backup file in notepad or notepadd ++ search for the script which says add database user. Either remove that script or remove/change the username in script. Then try to restore again.
     
Loading...